Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, When I Create A Task Using

Hi,
When i create a task using clearml-task specifying some hydra arguments the task correclty shows up in the web app with its arguments. But when i enqueue it (from the CLI or from the web app) no arguments are passed to the script.
For example running clearml-task --script train.py --args log.clearml=True train.epochs=200 clearml.save=True --project test --name test --skip-task-init (skip-task-init beacose i create the task if log.clearml=True ) in the web app it shows up like the screenshot but if I enqueue it and run it no arguments are passed to the script ( sys.argv is just the filename). I do understand that from clearml-task --help only argparse is supported
--args [ARGS [ARGS ...]] Arguments to pass to the remote execution, list of <argument>=<value> strings.Currently only argparse arguments are supported. Example: --args lr=0.003 batch_size=64but is there any workaround? Can you point me to the relevant files in clearml so i can add the support for hydra myself?

  
  
Posted one year ago
Votes Newest

Answers 5


Yes it uses hydra and everything works fine without clearml. The script is similar to this one https://github.com/galatolofederico/lightning-template/blob/main/train.py

  
  
Posted one year ago

When enqueued the configuration tab still shows the correct arguments

  
  
Posted one year ago

This is the full print(cfg)
{'dataset': {'name': '<my-dataset-name>', 'path': '', 'target_shape': [128, 128]}, 'model': 'unet', 'models': {'unet': {'dim': 8, 'dim_mults': [1, 2, 4], 'num_blocks_per_stage': [2, 2, 2], 'num_self_attn_per_stage': [0, 0, 1], 'nested_unet_depths': [0, 0, 0], 'nested_unet_dim': 16, 'use_convnext': False, 'resnet_groups': 2, 'consolidate_upsample_fmaps': True, 'weight_standardize': False, 'attn_heads': 2, 'attn_dim_head': 16}}, 'train': {'accelerator': 'auto', 'gpus': 1, 'epochs': 100, 'batch_size': 8, 'lr': 0.001, 'seed': -1, 'log_every_n_steps': 1, 'checkpoints': False, 'enable_checkpoints': False, 'save': ''}, 'clearml': {'project': '<project-name>', 'task': '<task-name>', 'output_uri': 's3://<myhost>/<mybucket>', 'save': False, 'tags': None}, 'log': {'clearml': False, 'log_images_every_steps': 100}}

  
  
Posted one year ago

Hi TrickyFox41 , does you script contains hydra integration? do you import hydra? using some configuration file?

  
  
Posted one year ago

But not argument is passed to the scripts. Here i am printing sys.argv

  
  
Posted one year ago