Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
<Edited> Two Things:

<edited> Two things: The release of ` clearml-agent ` was not announced in 🤯 ` clearml-agent ` seems outdated wrt requirements, making poetry and clearml-agent incompatible:` ERROR: Cannot install -r /tmp/cached-reqsroa73i6z.txt (line 14), -r /tmp/cached-reqsroa73i6z.txt (line 55) and jsonschema==3.2.0 because these package versions have conflicting dependencies. The conflict is caused by: The user requested jsonschema==3.2.0 clearml-agent 1.5.0 depends on jsonschema<3.3.0 and >=2.6.0 poetry 1.2.2 depends on jsonschema<5.0.0 and >=4.10.0 To fix this you could try to: 1. loosen the range of package versions you've specified 2. remove package versions to allow pip attempt to solve the dependency conflict ERROR: ResolutionImpossible: for help visit ` ` clearml_agent: ERROR: Could not install task requirements! `EDIT #2: Created https://github.com/allegroai/clearml-agent/issues/129 for follow up

  
  
Posted one year ago
Votes Newest

Answers 13


Hi UnevenDolphin73 ,
Thanks for bringing this to our attention!
BTW, there was no requirements change i the new agent version as far as I know, so perhaps this is simply a new requirement by poetry?

  
  
Posted one year ago

UnevenDolphin73 can you please check agent version v1.5.1rc0? This should fix the pip issue as well as the last error you've sent (basically a deprecated jsonschema usage issue that is now unsupported)

  
  
Posted one year ago

SuccessfulKoala55 This is due to the pip update in clearml-agent

  
  
Posted one year ago

At least as far as I can tell, nothing else has changed on our systems. Previous pip versions would warn about this, but not crash.

  
  
Posted one year ago

Well, you can still limit the pip version in the configuration

  
  
Posted one year ago

SuccessfulKoala55 This happens pip >= 22.3 btw.

Another semi-related issue is that I now encounter these kind of error messages:
clearml_agent: ERROR: __init__() got an unexpected keyword argument 'types'

  
  
Posted one year ago

Hm, I did not specify any specific versions previously. What was the previous default?

  
  
Posted one year ago

The last kind when launching the agents.
The former on task execution.

  
  
Posted one year ago

There's not much (or anything) in the log to provide...

` (.venv) 15:42 [0:user@server$~] CLEARML_CONFIG_FILE=~/agent_clearml.conf clearml-agent daemon --queue default on_prem --detached --order-fairness
Environment variables set from configuration: ['AWS_ACCESS_KEY_ID', 'AWS_SECRET_ACCESS_KEY', 'AWS_DEFAULT_REGION']

clearml_agent: ERROR: init() got an unexpected keyword argument 'types' `

  
  
Posted one year ago

Sorry for the late reply Jake -- I was away on holidays -- it works perfectly now, thanks!

  
  
Posted one year ago

UnevenDolphin73 when do you encounter these errors? When running clearml-agent daemon? Or during task execution? Can you attach some log to provide context?

  
  
Posted one year ago

These issues popped when I upgraded to clearml-agent 1.5.0.

  
  
Posted one year ago

Now I tried setting pip version to <22.3 (both in the config and in the scaler's "extra config parameters"), but still it uses the latest?

added seed packages: pip==22.3.1, setuptools==65.5.1, wheel==0.38.4

  
  
Posted one year ago
641 Views
13 Answers
one year ago
one year ago
Tags