Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hey, I'M Trying To Set Up A Clearml Server On Docker As Per Documentation. Everything Goes Well Until The Docker-Compose Up Step, That'S When I Get This Error; Error: Error Pulling Image Configuration: Download Failed After Attempts=6: X509: Certificate

Hey,
I'm trying to set up a clearml server on docker as per documentation.
Everything goes well until the docker-compose up step, that's when I get this error;

ERROR: error pulling image configuration: download failed after attempts=6: x509: certificate signed by unknown authority

This comes up as soon as it starts pulling elasticsearch, no leads on what to do, any help?

  
  
Posted one year ago
Votes Newest

Answers 13


WickedElephant66 this seems like a general network issue, like the docker service is missing your companies firewall certificate.
Can you pull any container from docker hub ?

  
  
Posted one year ago

version: "3.6"
services:

apiserver:
command:
apiserver
container_name: clearml-apiserver
image: allegroai/clearml:latest
restart: unless-stopped
volumes:
/opt/clearml/logs:/var/log/clearml
/opt/clearml/config:/opt/clearml/config
/opt/clearml/data/fileserver:/mnt/fileserver
depends_on:
redis
mongo
elasticsearch
fileserver
environment:
CLEARML_ELASTIC_SERVICE_HOST: elasticsearch
CLEARML_ELASTIC_SERVICE_PORT: 9200
CLEARML_ELASTIC_SERVICE_PASSWORD: ${ELASTIC_PASSWORD}
CLEARML_MONGODB_SERVICE_HOST: mongo
CLEARML_MONGODB_SERVICE_PORT: 27017
CLEARML_REDIS_SERVICE_HOST: redis
CLEARML_REDIS_SERVICE_PORT: 6379
CLEARML_SERVER_DEPLOYMENT_TYPE: ${CLEARML_SERVER_DEPLOYMENT_TYPE:-linux}
CLEARML__apiserver__pre_populate__enabled: "true"
CLEARML__apiserver__pre_populate__zip_files: "/opt/clearml/db-pre-populate"
CLEARML__apiserver__pre_populate__artifacts_path: "/mnt/fileserver"
ports:
"8008:8008"
networks:
backend
frontend

elasticsearch:
networks:
backend
container_name: clearml-elastic
environment:
ES_JAVA_OPTS: -Xms2g -Xmx2g -Dlog4j2.formatMsgNoLookups=true
ELASTIC_PASSWORD: ${ELASTIC_PASSWORD}
bootstrap.memory_lock: "true"
cluster.name: clearml
cluster.routing.allocation.node_initial_primaries_recoveries: "500"
cluster.routing.allocation.disk.watermark.low: 500mb
cluster.routing.allocation.disk.watermark.high: 500mb
cluster.routing.allocation.disk.watermark.flood_stage: 500mb
discovery.zen.minimum_master_nodes: "1"
discovery.type: "single-node"
http.compression_level: "7"
node.ingest: "true"
node.name: clearml
reindex.remote.whitelist: '.'
xpack.monitoring.enabled: "false"
xpack.security.enabled: "false"
ulimits:
memlock:
soft: -1
hard: -1
nofile:
soft: 65536
hard: 65536
image: http://docker.elastic.co/elasticsearch/elasticsearch:7.16.2
restart: unless-stopped
volumes:
/opt/clearml/data/elastic_7:/usr/share/elasticsearch/data
/usr/share/elasticsearch/logs

fileserver:
networks:
backend
frontend
command:
fileserver
container_name: clearml-fileserver
image: allegroai/clearml:latest
restart: unless-stopped
volumes:
/opt/clearml/logs:/var/log/clearml
/opt/clearml/data/fileserver:/mnt/fileserver
/opt/clearml/config:/opt/clearml/config
ports:
"8081:8081"

mongo:
networks:
backend
container_name: clearml-mongo
image: mongo:4.4.9
restart: unless-stopped
command: --setParameter internalQueryMaxBlockingSortMemoryUsageBytes= tel:196100200
volumes:
/opt/clearml/data/mongo_4/db:/data/db
/opt/clearml/data/mongo_4/configdb:/data/configdb

redis:
networks:
backend
container_name: clearml-redis
image: redis:5.0
restart: unless-stopped
volumes:
/opt/clearml/data/redis:/data

webserver:
command:
webserver
container_name: clearml-webserver
# environment:
# CLEARML_SERVER_SUB_PATH : clearml-web # Allow Clearml to be served with a URL path prefix.
image: allegroai/clearml:latest
restart: unless-stopped
depends_on:
apiserver
ports:
"8080:80"
networks:
backend
frontend

agent-services:
networks:
backend
container_name: clearml-agent-services
image: allegroai/clearml-agent-services:latest
deploy:
restart_policy:
condition: on-failure
privileged: true
environment:
CLEARML_HOST_IP: ${CLEARML_HOST_IP}
CLEARML_WEB_HOST: ${CLEARML_WEB_HOST:-}
CLEARML_API_HOST: http://apiserver:8008
CLEARML_FILES_HOST: ${CLEARML_FILES_HOST:-}
CLEARML_API_ACCESS_KEY: ${CLEARML_API_ACCESS_KEY:-}
CLEARML_API_SECRET_KEY: ${CLEARML_API_SECRET_KEY:-}
CLEARML_AGENT_GIT_USER: ${CLEARML_AGENT_GIT_USER}
CLEARML_AGENT_GIT_PASS: ${CLEARML_AGENT_GIT_PASS}
CLEARML_AGENT_UPDATE_VERSION: ${CLEARML_AGENT_UPDATE_VERSION:-">=0.17.0"}
CLEARML_AGENT_DEFAULT_BASE_DOCKER: "ubuntu:18.04"
AWS_ACCESS_KEY_ID: ${AWS_ACCESS_KEY_ID:-}
AWS_SECRET_ACCESS_KEY: ${AWS_SECRET_ACCESS_KEY:-}
AWS_DEFAULT_REGION: ${AWS_DEFAULT_REGION:-}
AZURE_STORAGE_ACCOUNT: ${AZURE_STORAGE_ACCOUNT:-}
AZURE_STORAGE_KEY: ${AZURE_STORAGE_KEY:-}
GOOGLE_APPLICATION_CREDENTIALS: ${GOOGLE_APPLICATION_CREDENTIALS:-}
CLEARML_WORKER_ID: "clearml-services"
CLEARML_AGENT_DOCKER_HOST_MOUNT: "/opt/clearml/agent:/root/.clearml"
SHUTDOWN_IF_NO_ACCESS_KEY: 1
volumes:
/var/run/docker.sock:/var/run/docker.sock
/opt/clearml/agent:/root/.clearml
depends_on:
apiserver
entrypoint: >
bash -c "curl --retry 10 --retry-delay 10 --retry-connrefused ' http://apiserver:8008/debug.ping ' && /usr/agent/entrypoint.sh"

networks:
backend:
driver: bridge
frontend:
driver: bridge

  
  
Posted one year ago

Or maybe I'm wrong

  
  
Posted one year ago

I can't see any reason it should not work 😀

  
  
Posted one year ago

I suppose the issue is only with the elastic search registry

  
  
Posted one year ago

Alright then, the server worked as it should so far, thanks 😄

  
  
Posted one year ago

So, I replaced line 65 in your docker-compose file with image: elasticsearch:7.16.2 so that it pulls the image from the dockerhub registry than the registry at http://docker.elastic.co , I just want to confirm if this is okay with the functioning of clearml

  
  
Posted one year ago

WickedElephant66 which version of the docker-compose.yml file are you using? Can you paste it here?

  
  
Posted one year ago

Because it is pulling from http://docker.elastic.co , can I replace that one with the image available on docker hub?

  
  
Posted one year ago

It's the same file from the raw github link

  
  
Posted one year ago

So for some reason you have an issue pulling from dockerhub in your Network?

  
  
Posted one year ago

hurray 🎊

  
  
Posted one year ago

Yes, I can pull other containers from dockerhub

  
  
Posted one year ago
614 Views
13 Answers
one year ago
one year ago
Tags