Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi All. I'M Having Some Issues Authenticating With Clearml In Google Colab. Here'S What I Did Locally, Which Worked:

Hi all. I'm having some issues authenticating with ClearML in Google Colab. Here's what I did locally, which worked:
installed clearml performed clearml-init to create a config file open a Python shell from clearml import Task Task.get_projects()
But then, if I do the following:
Copy the exact same clearml.conf from my local home directory to /root/clearml.conf on Google Colab install clearml Try to list projects as above
I get a time out:
Retrying (Retry(total=239, connect=239, read=240, redirect=240, status=240)) after connection broken by 'NewConnectionError('<urllib3.connection.HTTPSConnection object at 0x7f0f1e999690>: Failed to establish a new connection: [Errno -2] Name or service not known')': /auth.login
Any suggestions?

  
  
Posted 2 years ago
Votes Newest

Answers 11


Yes, I can verify the location, I'm uploading the file and then running:
! cp clearml.conf ~/clearml.conf

  
  
Posted 2 years ago

Same result

  
  
Posted 2 years ago

Hi GleamingGrasshopper63 ,

ClearML will take you configuration from ~/clearml.conf file (so it should use the file if you are root user). You can also configure env var for you auth and api work:

export CLEARML_API_HOST={api_server} export CLEARML_WEB_HOST={web_server} export CLEARML_FILES_HOST={files_server} export CLEARML_API_ACCESS_KEY={access_key} export CLEARML_API_SECRET_KEY={secret_key}Can you verify the configuration file location or try with the env vars?

  
  
Posted 2 years ago

I also tried setting it with the library manually using
Task.set_credentials(web_host=web_server, api_host=api_server,files_host=files_server, key=access_key, secret=secret_key )

  
  
Posted 2 years ago

can you try with

import os os.environ["CLEARML_CONFIG_FILE"] = "/root/clearml.conf"at the top?

  
  
Posted 2 years ago

whats the clearml version you are using?

  
  
Posted 2 years ago

1.1.5 both locally and on Google Colab

  
  
Posted 2 years ago

Same result

  
  
Posted 2 years ago

Sure. Just a sec.

  
  
Posted 2 years ago

GleamingGrasshopper63 can you ping to your api server ?
!ping api.server.hereAlso what's the api server you configured ? (ip:8008 ?)
Any chance this is a Local machine, i.e. the colab machine cannot get back into the clearml server cunning locally ?

  
  
Posted 2 years ago
505 Views
11 Answers
2 years ago
one year ago
Tags