Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, I’M Using

Hi, I’m using PipelineDecorator.component to integrate the training task to a big pipeline. How could I turn off model logging when running this training step? (When using Task.init to build a ClearML task, I usually set auto_connect_frameworks ={‘pytorch’: False}.)

Additionally, I wish to use clearml.OutputModel to manually log model during the execution of the training step.

  
  
Posted 2 years ago
Votes Newest

Answers 5


AgitatedDove14 This make sense. Hope we can have this argument in the next ClearML version 😄

  
  
Posted 2 years ago

GrittyKangaroo27 any chance you can open a GitHub issue so this is not forgotten ?
(btw: we I think 1.1.6 is going to be released later today, then we will have a few RC with improvements on the pipeline, I will make sure we add that as well)

  
  
Posted 2 years ago

Thanks!

  
  
Posted 2 years ago

Hi GrittyKangaroo27

How could I turn off model logging when running this training step?

This is a good point! I think we cannot pass these arguments.
Would this make sense to you?
PipelineDecorator.component(..., auto_connect_frameworks)
wdyt?

  
  
Posted 2 years ago

AgitatedDove14 Sure

  
  
Posted 2 years ago