Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
I’M Getting 404 Errors When Trying To Click Links For Notebook Artifacts And I’M Trying To Figure Out If It’S The File Or If It’S The File Server. Is There Some Sort Of Endpoint We Can Hit On The Fileserver To Verify It’S Available?

i’m getting 404 errors when trying to click links for notebook artifacts and i’m trying to figure out if it’s the file or if it’s the file server. is there some sort of endpoint we can hit on the fileserver to verify it’s available?

  
  
Posted 2 years ago
Votes Newest

Answers 31


yeah i can and it comes back 200

  
  
Posted 2 years ago

` {
"meta": {
"id": "aac901e3e58c4381852b0fe1d227c732",
"trx": "aac901e3e58c4381852b0fe1d227c732",
"endpoint": {
"name": "login.supported_modes",
"requested_version": "2.13",
"actual_version": "1.0"
},
"result_code": 200,
"result_subcode": 0,
"result_msg": "OK",
"error_stack": "",
"error_data": {

}

},
"data": {
"authenticated": false,
"basic": {
"enabled": false,
"guest": {
"enabled": false
}
},
"server_errors": {
"es_connection_error": false,
"missed_es_upgrade": false
},
"sso": {

},
"sso_providers": [
  
]

}
} `that's what the browser returns

  
  
Posted 2 years ago

seems to only happen when going through the app

  
  
Posted 2 years ago

Cab you do:
curl

  
  
Posted 2 years ago

Yes, the webserver doesn't know where the api server is, it will access /api and then the nginx running the webapp will do the routing (reverse proxy)
I think that for some reason it is failing to do that (actually similarly to the stackoverflow you linked)

  
  
Posted 2 years ago

Nice!

  
  
Posted 2 years ago

if i hit the api directly it returns fine

  
  
Posted 2 years ago

image

  
  
Posted 2 years ago

he said it was something in the nginx config though

That makes sense 🙂

  
  
Posted 2 years ago

we got it running. waiting for my coworker to give me the summary of what he did... he said it was something in the nginx config though

  
  
Posted 2 years ago

so it seems to be how istio is handling the routing. if we use the internal service address in the nginx configs it seems to go ok.

  
  
Posted 2 years ago

looks like he hardcoded the api fqdn in proxy_set_header Host instead of using $host

  
  
Posted 2 years ago

It looks somewhat familiar ... 😞
SuccessfulKoala55 any idea?

  
  
Posted 2 years ago

but there are a bunch of 405 errors in the log

  
  
Posted 2 years ago

he's still messing around though

  
  
Posted 2 years ago

have you seen this happen before?

  
  
Posted 2 years ago

webserver

  
  
Posted 2 years ago

looks like at the end of the day we removed 

proxy_set_header Host $host;

  and use the fqdn for the proxy_pass line

And did that solve the issue?

  
  
Posted 2 years ago

looks like at the end of the day we removed proxy_set_header Host $host; and use the fqdn for the proxy_pass line

  
  
Posted 2 years ago

istio expects a certain host and whatever is getting passed by the pod isn't right.

  
  
Posted 2 years ago

istio routes based off of hostname so the app hostname was being passed causing the loop

  
  
Posted 2 years ago

we removed that and it was all good

  
  
Posted 2 years ago

yes it did

  
  
Posted 2 years ago

FloppyDeer99 what am I seeing in the screenshot ?

But why the url in es is different from it in web UI?

They are not really different, but sometimes the "url quote" is an issue (this is the process a browser will take a string url like a/b and convert it to a%2fb ),
I remember that there was an issue involving double quoting (this is when you have: a/b -> a%2fb -> a%252fb ), notice the last one replace "%" with "%25" as in your example...
Let me know if the latest clearml version solves it

  
  
Posted 2 years ago

Hi FloppyDeer99
Since this thread is a bit old, I might have missed something 🙂
Are we saying the links are not working in the UI ?
(notice the links themselves are generated by the clearml package, so if there was a bug, still not sure here, then old links will remain invalid until manually fixed) Can you verify that the latest clearml generates working links?

  
  
Posted 2 years ago

AgitatedDove14 , I will try it with latest version. But why the url in es is different from it in web UI? I have checked the codes that evnets.debug_images api which will return url to web UI will get the url from es.

code commit

  
  
Posted 2 years ago

I meet the same problem.
I curl elastic and get the following result(picture 1).
I check the response of debug images from web UI, and I get the picture2.

version

I deploy clearml in 1.1.1 with helm, and use 1.0.4 clearml package.

  
  
Posted 2 years ago

Hi BurlySeagull48 AgitatedDove14 , does upgrading clearml package and images to 1.0.4 really work? https://clearml.slack.com/archives/CTK20V944/p1628112607184300?thread_ts=1628108536.180100&cid=CTK20V944

  
  
Posted 2 years ago

the issue moving forward is if we restart the pod we will have to manually update that again.

Can't you map the nginx configuration file ? (making the changes persistent across pods)

  
  
Posted 2 years ago

the issue moving forward is if we restart the pod we will have to manually update that again. similar to what we were doing prior to the http 1.1 setting being put in place.

  
  
Posted 2 years ago