Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, I Restarted My Clearml-Server (1.1.0) And The Login Page Always Redirects Me To The Login Page. I Am Using Fixed Users In Config Files. In The Logs Of The Api Server I Can See:

Hi, I restarted my clearml-server (1.1.0) and the login page always redirects me to the login page. I am using fixed users in config files. In the logs of the api server I can see:
clearml-apiserver | [2021-08-11 06:55:20,519] [8] [WARNING] [clearml.service_repo] Returned 401 for users.get_preferences in 0ms, msg=Unauthorized (missing credentials)Any idea what’s wrong? I tried with both firefox/chrome and cleared cache/cookies

  
  
Posted 2 years ago
Votes Newest

Answers 15


Hi JitteryCoyote63 ,
This initial error will be there most of the times since the WebApp tries to access, gets an error, and than gets redirected to the login. The question is why the login page doesn't work

  
  
Posted 2 years ago

Can you show me the browser's network tab when you try to login?

  
  
Posted 2 years ago

The console errors are inconsequential

  
  
Posted 2 years ago

SuccessfulKoala55 I found the issue thanks to you: I changed a bit the domain but didn’t update the apiserver.auth.cookies.domain setting - I did it, restarted and now it works 🙂 Thanks!

  
  
Posted 2 years ago

Yes, I set:
auth { cookies { httponly: true secure: true domain: ".clearml.xyz.com" max_age: 99999999999 } }It always worked for me this way

  
  
Posted 2 years ago

Can I see the response headers from the auth.login call? Specifically, the set cookie header - I suspect the cookie might be domain-specific and thus not stored by the browser (since I can't see it used in the following requests)

  
  
Posted 2 years ago

However, the server returns auth.login with 200 , so the question is why isn't the token generated by that response stored in the browser

  
  
Posted 2 years ago

Did you set it somewhere? This is usually done in the apiserver.auth.cookis.domain setting

  
  
Posted 2 years ago

The default is no domain (null)

  
  
Posted 2 years ago

See the Set-Cookie header, it specifies Domain: .clearml. , which probably causes the browser to ignore the cookie and not set it in the session

  
  
Posted 2 years ago

Can you show the response for the auth.login call and the request and headers for the following calls?

  
  
Posted 2 years ago

image

  
  
Posted 2 years ago

image
image
image

  
  
Posted 2 years ago

image

  
  
Posted 2 years ago

Here is the console with some errors

  
  
Posted 2 years ago
670 Views
15 Answers
2 years ago
one month ago
Tags