Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
If I Set

if I set

# set the post packages to be installed after all the rest of the required packages # post_packages: ["google-cloud-storage", ]
will it always run pip isntall google-cloud-storage or do I have to run it myself?

  
  
Posted 3 years ago
Votes Newest

Answers 20


If you want to quickly test it:
pip install clearml-agent
Then assuming Task id is aabbcc
Run
clearml-agent execute --id aabbccYou should be able to trace if the package was installed

  
  
Posted 3 years ago

I tried to add it to post_packages and run it locally, for some reason it didn't install googlecloud-storage. However it is possible that I have an old clearml pip package installed

  
  
Posted 3 years ago

I have another problem at the moment (some packages that are not inside the cache seem to have be missing and then everything fails)

  
  
Posted 3 years ago

(it will just create a new venv and install everything you need in the venv)

  
  
Posted 3 years ago

Ok

  
  
Posted 3 years ago

ERROR: Could not find a version that satisfies the requirement pandas==1.2.4 (from -r /tmp/cached-reqs1i9hihyv.txt (line 14)) (from versions: 0.1, 0.2b0, 0.2b1, 0.2, 0.3.0b0, 0.3.0b2, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.5.0, 0.6.0, 0.6.1, 0.7.0rc1, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0rc1, 0.8.0rc2, 0.8.0, 0.8.1, 0.9.0, 0.9.1, 0.10.0, 0.10.1, 0.11.0, 0.12.0, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.15.0, 0.15.1, 0.15.2, 0.16.0, 0.16.1, 0.16.2, 0.17.0, 0.17.1, 0.18.0, 0.18.1, 0.19.0rc1, 0.19.0, 0.19.1, 0.19.2, 0.20.0rc1, 0.20.0, 0.20.1, 0.20.2, 0.20.3, 0.21.0rc1, 0.21.0, 0.21.1, 0.22.0, 0.23.0rc2, 0.23.0, 0.23.1, 0.23.2, 0.23.3, 0.23.4, 0.24.0rc1, 0.24.0, 0.24.1, 0.24.2, 0.25.0rc0, 0.25.0, 0.25.1, 0.25.2, 0.25.3, 1.0.0rc0, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.1.0rc0, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5)
ERROR: No matching distribution found for pandas==1.2.4 (from -r /tmp/cached-reqs1i9hihyv.txt (line 14))

  
  
Posted 3 years ago

I will have to remove some parts because it contains some sensitive data

  
  
Posted 3 years ago

I don't know, I only see the error

  
  
Posted 3 years ago

Can you send the full log ?

  
  
Posted 3 years ago

sure

  
  
Posted 3 years ago

and run it locally...

You mean you run the clearml-agent locally ?

  
  
Posted 3 years ago

DefiantCrab67
It will always install it on any environment

  
  
Posted 3 years ago

yea

  
  
Posted 3 years ago

(some packages that are not inside the cache seem to have be missing and then everything fails)

How did that happen?

  
  
Posted 3 years ago

ERROR: No matching distribution found for pandas==1.2.4 (from -r /tmp/cached-reqs1i9hihyv.txt (line 14))

  
  
Posted 3 years ago

(after all the other packages are installed)

  
  
Posted 3 years ago

post_optional_packages: ["google-cloud-storage", ]Will install it last (i.e. after all the other packages) but only if you have it in the "Installed packages" list

  
  
Posted 3 years ago

on my own machine

  
  
Posted 3 years ago

sure 🙂

  
  
Posted 3 years ago

Do you mind if I send it in a private chat?

  
  
Posted 3 years ago
654 Views
20 Answers
3 years ago
one year ago
Tags