Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Fyi: Conda Installation Of Pytorch Is Broken Again. My Old Tasks Which Worked Before Now Fail Since They Do Not Find Torch. However, I Can See In The Execution That Conda Had Errors. Most Probably It Happens Because Pytorch 1.8.1 Has Been Released, But I

Fyi: Conda installation of PyTorch is broken again. My old tasks which worked before now fail since they do not find torch. However, I can see in the execution that conda had errors. Most probably it happens because pytorch 1.8.1 has been released, but I am not sure. Gonna test now.
However, clearml-agent should throw an error when conda errors and not just continue running:

Executing Conda: /home/tim/miniconda3/condabin/conda install -p /home/tim/.clearml/venvs-builds/3.7 -c pytorch -c conda-forge -c defaults 'pip<20.2' --quiet --json Pass Conda: Trying to install requirements: ['blas~=1.0', 'bzip2~=1.0.8', 'ca-certificates~=2021.1.19', 'certifi~=2020.12.5', 'cloudpickle~=1.6.0', 'cudatoolkit~=11.1.1', 'cycler~=0.10.0', 'cytoolz~=0.11.0', 'dask-core~=2021.2.0', 'decorator~=4.4.2', 'ffmpeg~=4.3', 'freetype~=2.10.4', 'gmp~=6.2.1', 'gnutls~=3.6.13', 'imageio~=2.9.0', 'jpeg~=9b.0', 'kiwisolver~=1.3.1', 'lame~=3.100', 'lcms2~=2.11', 'ld_impl_linux-64~=2.33.1', 'libedit~=3.1.20191231', 'libffi~=3.3', 'libgcc-ng~=9.3.0', 'libgfortran-ng~=7.3.0', 'libiconv~=1.16', 'libpng~=1.6.37', 'libstdcxx-ng~=9.3.0', 'libtiff~=4.1.0', 'libuv~=1.41.0', 'llvm-openmp~=11.0.1', 'lz4-c~=1.9.3', 'matplotlib-base~=3.3.4', 'mkl~=2020.4', 'mkl-service~=2.3.0', 'mkl_fft~=1.3.0', 'mkl_random~=1.2.0', 'ncurses~=6.2', 'nettle~=3.6', 'networkx~=2.5', 'ninja~=1.10.2', 'olefile~=0.46', 'openh264~=2.1.1', 'openssl~=1.1.1j', 'pyparsing~=2.4.7', 'python~=3.7.10', 'python-dateutil~=2.8.1', 'python_abi~=3.7', 'pytorch~=1.8.0', 'pywavelets~=1.1.1', 'pyyaml~=5.4.1', 'readline~=8.1', 'scikit-image~=0.17.2', 'scipy~=1.6.1', 'setuptools~=52.0.0', 'six~=1.15.0', 'sqlite~=3.33.0', 'tifffile~=2020.10.1', 'tk~=8.6.10', 'toolz~=0.11.1', 'torchaudio~=0.8.0', 'torchvision~=0.9.0', 'tornado~=6.1', 'typing_extensions~=3.7.4.3', 'wheel~=0.36.2', 'xz~=5.2.5', 'yaml~=0.2.5', 'zlib~=1.2.11', 'zstd~=1.4.9'] Executing Conda: /home/tim/miniconda3/condabin/conda env update -p /home/tim/.clearml/venvs-builds/3.7 --file /tmp/conda_envczuhjouv.yml --quiet --json 2021-03-25 18:19:17 Conda error: Multiple Errors Encountered. Conda: Installing requirements: step 2 - using pip: ...

  
  
Posted 3 years ago
Votes Newest

Answers 15


ReassuredTiger98
(for some reason it kind of jumps over PyTorch, but then installs torchvision?!)
Could you run with the latest with --debug
We just added but you will have to install from git:
pip3 install git+Then run with --debug:
clearml-agent --debug daemon ...

  
  
Posted 3 years ago

Yea I know, I reported this

LOL, apologies these days it a miracle I still remember my login passwords 😉

  
  
Posted 3 years ago

Give me 5min and I send the full log

  
  
Posted 3 years ago

Here is the log

  
  
Posted 3 years ago

I got some warnings about broken packages. I cleaned the conda cache with conda clean -a ` and now it installed fine!

  
  
Posted 3 years ago

Will be shortly released with news RC :)

  
  
Posted 3 years ago

nice 🙂

  
  
Posted 3 years ago

My pleasure

  
  
Posted 3 years ago

ReassuredTiger98 can you send the full log?
Also, what's the clearml-agent version?
fyi: we fixed an issue where the default order of the conda repositories cause pytorch to be installed form the conda forge instead of the pytorch repo, making it the cpu version instead of the gpu version:
This is the correct conda repo orderL
https://github.com/allegroai/clearml-agent/blob/cb6bdece39751eaef975287609b8bab603f116e5/docs/clearml.conf#L66

  
  
Posted 3 years ago

Hi ReassuredTiger98 ,
Completely understand regarding the conda errors issue, however I'm not sure it's always easily detectable - I think AgitatedDove14 probably has some insight on that.

Gonna test now.

Please update when you have more info 🙂

  
  
Posted 3 years ago

Thank you for helping!

  
  
Posted 3 years ago

Yea I know, I reported this 🙂 .

  
  
Posted 3 years ago

Good to know the --debug flag exists in master! 😄

  
  
Posted 3 years ago

Installed packages:

` # Python 3.7.10 (default, Feb 26 2021, 18:47:35) [GCC 7.3.0]

absl-py==0.12.0
aiostream==0.4.2
attrs==20.3.0
cached-property==1.5.2
cffi==1.14.5
chardet==4.0.0
clearml==0.17.5
cython==0.29.22
dm-control==0.0.364896371
dm-env==1.4
dm-tree==0.1.5
fasteners==0.16
furl==2.1.0
future==0.18.2
glfw==2.1.0
gym==0.18.0
h5py==3.2.1
humanfriendly==9.1
idna==2.10
imageio-ffmpeg==0.4.3
importlib-metadata==3.7.3
jsonschema==3.2.0
labmaze==1.0.4
lxml==4.6.3
moviepy==1.0.3
mujoco-py==2.0.2.13
orderedmultidict==1.0.1
pathlib2==2.3.5
pillow==7.2.0
proglog==0.1.9
protobuf==3.15.6
psutil==5.8.0
pybullet==3.1.0
pycparser==2.20
pygame==2.0.1
pyglet==1.5.0
pyjwt==2.0.1
pyopengl==3.1.5
pyrsistent==0.17.3
requests==2.25.1
tensorboardx==2.1
tqdm==4.59.0
urllib3==1.26.4
zipp==3.4.1

Conda Packages

blas==1.0
blosc==1.21.0
brotli==1.0.9
bzip2==1.0.8
ca-certificates==2021.1.19
certifi==2020.12.5
charls==2.1.0
cloudpickle==1.6.0
cudatoolkit==11.1.1
cycler==0.10.0
cytoolz==0.11.0
dask-core==2021.3.0
decorator==4.4.2
ffmpeg==4.3
freetype==2.10.4
giflib==5.1.9
gmp==6.2.1
gnutls==3.6.13
imagecodecs==2020.5.30
imageio==2.9.0
jpeg==9b
jxrlib==1.1
kiwisolver==1.3.1
lame==3.100
lcms2==2.11
ld_impl_linux-64==2.33.1
libaec==1.0.4
libffi==3.3
libgcc-ng==9.3.0
libgfortran-ng==7.3.0
libiconv==1.16
libpng==1.6.37
libstdcxx-ng==9.3.0
libtiff==4.1.0
libuv==1.41.0
libwebp==1.0.0
libzopfli==1.0.3
llvm-openmp==11.1.0
lz4-c==1.9.3
matplotlib-base==3.3.4
mkl==2020.4
mkl-service==2.3.0
mkl_fft==1.3.0
mkl_random==1.2.0
ncurses==6.2
nettle==3.6
networkx==2.5
ninja==1.10.2
numpy==1.19.2
numpy-base==1.19.2
olefile==0.46
openh264==2.1.1
openjpeg==2.4.0
openssl==1.1.1k
pip==21.0.1
pyparsing==2.4.7
python==3.7.10
python-dateutil==2.8.1
python_abi==3.7
torch==1.8.1
pywavelets==1.1.1
pyyaml==5.4.1
readline==8.1
scikit-image==0.17.2
scipy==1.6.1
setuptools==52.0.0
six==1.15.0
snappy==1.1.8
sqlite==3.35.2
tifffile==2020.10.1
tk==8.6.10
toolz==0.11.1
torchaudio==0.8.1
torchvision==0.9.1
tornado==6.1
typing_extensions==3.7.4.3
wheel==0.36.2
xz==5.2.5
yaml==0.2.5
zlib==1.2.11
zstd==1.4.9 `

  
  
Posted 3 years ago

Yey!

  
  
Posted 3 years ago
612 Views
15 Answers
3 years ago
one year ago
Tags