Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi! I Have A Clearml Offline Mode Question, In The Docs It Says That When Importing An Offline Session "Full Task Execution Includes Repository Details, Installed Packages, Artifacts, Logs, Metric And Debug Samples." I Am Trying To Figure Out How To Get T

Hi! I have a ClearML offline mode question,
In the docs it says that when importing an offline session "Full Task execution includes repository details, installed packages, artifacts, logs, metric and debug samples." I am trying to figure out how to get this full functionality with the below flow:
In my local setup I have set the trains.conf-> development.default_output_uri to point to my fileserver. As long as I'm online the artifacts \ models are uploaded automatically. when I run my code on some remote machine that doesn't have access to my fileserver, I later use the import_offline_session method to register \ sync the task with my local server.
What adjustments do I need on the remote machine (maybe default_output_uri) to make the import take care of all the artifacts uploading?? Thanks!

  
  
Posted 3 years ago
Votes Newest

Answers 9


Hi RipeGoose2
I think it "should" take of uploading the artifacts as well (they are included in the zip file created by the offline package)
Notice that the "default_output_uri" on the remote machine is meaningless as it stored them locally anyhow. It will only have an effect on the machine that actually imports the offline session.
Make sense ?

  
  
Posted 3 years ago

is there a built in programmatic way to adjust 

development.default_output_uri

?

How about: In your Task.init(output_uri='...')

  
  
Posted 3 years ago

Thanks AgitatedDove14 , well if a machine doesn't set the default_output_uri, the default behavior for model checkpoints for example is to just register without uploading. So in the case that the default_output_uri is not defined the offline task folder will not have the artifacts for uploading (not included in the zip file created by offline package).. or am I missing something?

  
  
Posted 3 years ago

thanks!

  
  
Posted 3 years ago

uploading artifacts

if you call task.upload_artifact(...) , there is no need to set output_uri. If you want models to be uploaded (e.g. torch.save(...) ) only then you have to set output_uri.

Otherwise correct 🙂

  
  
Posted 3 years ago

is there a built in programmatic way to adjust development.default_output_uri ?

  
  
Posted 3 years ago

cool, AgitatedDove14 so just to confirm:
To get the desired behavior, uploading artifacts on import_offline_session
The needed action is: setting the development.default_output_uri in the offline machine run (and nothing else?)

  
  
Posted 3 years ago

great, I'm going to give it a try

  
  
Posted 3 years ago

Yes RipeGoose2 you are totally correct 🙂 if you want the models to be auto uploaded in the offline session you have to pass output_uri (or default_output_uri).

  
  
Posted 3 years ago
731 Views
9 Answers
3 years ago
one year ago
Tags