Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, I’M Trying To Setup The Trains Server On My Own Computer And Everything Is Fine Until I Need To Create New Credentials, Is Pop Up A Window Say “Unable To Create Credentials” I’M Not Sure If I Missed Something And How Can I Check? Btw, I Couldn’T Run

Hi, i’m trying to setup the trains server on my own computer and everything is fine until i need to create new credentials, is pop up a window say “Unable to create credentials” i’m not sure if i missed something and how can i check?
btw, i couldn’t run docker-compose w/o sudo, not sure if this is relevant (this problem is fixed).
Appreciate any help!

  
  
Posted 3 years ago
Votes Newest

Answers 17


i tired to run trains-compose without -d to say the log,
trains-agent-services | trains_agent: ERROR: Connection Error: it seems api_server is misconfigured. Is this the TRAINS API server http://apiserver:8008 ?
trains-agent-services | http://192.5.53.86:8081 http://192.5.53.86:8080 http://apiserver:8008
I didn’t assign anything to TRAINS_HOST_IP, not sure if the apiserver:8008 caused the problem

  
  
Posted 3 years ago

You can actually check the "Workers and Queues" page in the server to see if the Trains Agent Services instance running on the server machine is showing there. If not, I suggest setting TRAINS_HOST_IP to the correct IP so that the agent services instance will be able to communicate with the API server.

  
  
Posted 3 years ago

PompousHawk82 look here: https://allegroai-trains.slack.com/archives/CTK20V944/p1605816472498800?thread_ts=1605814409.497600&cid=CTK20V944
You'll have to make sure both 8080 , 8081 and 8008 are tunneled

  
  
Posted 3 years ago

I have two laptop, one is running ubuntu 20.04 and one is macos, both are running in my local network. I installed the server on ubuntu and ssh from mac to it to bring up the server then build up a tunnel using ssh -L

  
  
Posted 3 years ago

but the solution in the answer doesn’t help cause when i do reverse with -R the server couldn’t be brought up

  
  
Posted 3 years ago

i’ll finish my breakfast real quick and get in couple minuets

  
  
Posted 3 years ago

Thanks, it seems i need to forward all three ports

  
  
Posted 3 years ago

How did you configure the server exactly?

  
  
Posted 3 years ago

Then access the 8008 through the tunnel

  
  
Posted 3 years ago

Here is the screenshot

  
  
Posted 3 years ago

Yeah, you probably only need port forwarding ( -L ), not remote forwarding

  
  
Posted 3 years ago

You are awesome, thanks again!

  
  
Posted 3 years ago

Appreciated it!

  
  
Posted 3 years ago

It indeed looks like the WebApp simply can't reach the server. You probably have a firewall set up, blocking access to the server's 8008 port

  
  
Posted 3 years ago

Hi PompousHawk82 ,
From your description it sounds like the WebApp running on your browser cannot reach the Trains API Server running on the server you installed in port 8008 .
Can you provide some more information? The screenshot of your browser's developer tools window ( F12 ) showing the Network tab would help.
Also, try entering the following in a browser window and see if you get any response: http://<your-server-address>:8008/

  
  
Posted 3 years ago

btw, i couldn’t run docker-compose w/o sudo, not sure if this is relevant (this problem is fixed).

This should not be a problem, it mostly depends on how your system was set up. Let's try to figure out your original issue and make sure this doesn't affect it

  
  
Posted 3 years ago

i’m trying to install it my lab server, but the same problem happen, when i try to create credentials, it say error but this time it give more info:
Error 301 : Invalid user id: id=f46262bde88b4928997351a657901d8b, company=d1bd92a3b039400cbafc60a7a5b1e52b

  
  
Posted 3 years ago
622 Views
17 Answers
3 years ago
one year ago
Tags