Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi

Hi 👋 I am trying to set up a trains server on GCP. I followed all the steps listed here https://allegro.ai/docs/deploying_trains/trains_server_gcp/ . I also enabled https access and opened ports 8080, 8008, and 8081. I am having trouble with two things and would appreciate if someone could give me a hand:
How can I check the server dashboard to make sure everything is working? I have tried to access the external ip through https but the browser is not able to connect. I want to configure the authentication but apiserver.conf file does not exist, should I just create it?

  
  
Posted 2 years ago
Votes Newest

Answers 15


I suggest you take another look at the firewall configuration - maybe try to use more relaxing rules (like the option to open all http communication when creating the instance), see if it works, and try limiting from there...

  
  
Posted 2 years ago

Also, try entering http://<External IP>:8008 in the browser and see what you get

  
  
Posted 2 years ago

Hi GrievingTurkey78

How can I check the server dashboard to make sure everything is working? I have tried to access the external ip through https but the browser is not able to connect.

What do you mean by the server dashboard ?

regrading (2) see here: https://allegro.ai/docs/faq/faq/#web-auth

  
  
Posted 2 years ago

I enabled both https and http

  
  
Posted 2 years ago

Hi AgitatedDove14 thanks for your reply, with the dashboard I meant the Web-App (UI) . I am trying to access http://<External IP>:8080 but unfortunately nothing shows up.

  
  
Posted 2 years ago

Also, should I allow 8080 , 8008 , and 8081 on ingress and egress on GCP or is only egress enough?

  
  
Posted 2 years ago

I configured a firewall rule that opened the ports for the instance (not 100% sure if this is the right way) using network tags. Yes, the whole screen is black and no trains logo show up: Safari can’t open the page because the server where this page is located isn’t responding.

  
  
Posted 2 years ago

GrievingTurkey78 did you open the 8008 / 8080 / 8081 ports on your GCP instance (I have to admit I can't remember where exactly in the admin panel you do that, but I can assure you it is there :)

  
  
Posted 2 years ago

SuccessfulKoala55 just to let you know: since I opened the link straight from the GCP console it was using https on the address instead of http hence the error. Thanks a lot for your help!

  
  
Posted 2 years ago

Well, it sure looks like a network configuration issue...

  
  
Posted 2 years ago

GrievingTurkey78

unfortunately nothing shows up

when you say "nothing shows up", do you mean you see a black screen? do you see the trains logo? or does it appear like there's no response from the server and the page seems to keep loading with nothing showing up (i.e. white background)?

I also enabled https access and opened ports 8080, 8008

Did you enable just https or also http ?

  
  
Posted 2 years ago

Can you open the Safari's developer tools (in the Network section), reload the page and see if any requests are being answered at all?

  
  
Posted 2 years ago

Thanks SuccessfulKoala55 I’ll give it a try!

  
  
Posted 2 years ago

SuccessfulKoala55 on both 8080 and 8008 I get: Safari can’t open the page http://<External IP>:80XX because Safari can’t establish a secure connection to the server http://<External IP>:80XX .

  
  
Posted 2 years ago

I think ingress should be enough...

  
  
Posted 2 years ago