Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
The Path /Opt/Trains/Data/Elastic_7/Nodes Exists I Can Also See In The Logs: Trains_Agent: Error: Failed Getting Token (Error 401 From

the path /opt/trains/data/elastic_7/nodes exists
I can also see in the logs:
trains_agent: ERROR: Failed getting token (error 401 from http://apiserver:8008 ): Unauthorized (invalid credentials) (failed to locate provided credentials)

  
  
Posted 3 years ago
Votes Newest

Answers 30


Where do you see that error?

  
  
Posted 3 years ago

Yes it seems so

  
  
Posted 3 years ago

Does not work with domain name:
Blocked: The Same Origin Policy disallows reading the remote resource at http://trains.shapedo.com:8008/v2.9/users.get_current_user

  
  
Posted 3 years ago

ah no, same issue with IPS:
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://108.128.174.211:8008/v2.9/auth.fixed_users_mode .

  
  
Posted 3 years ago

Ok, running now from:
https://trains.shapedo.com/dashboard

When the DNS populates it will also have letsencrypt sign it. so I have https and a password protected login

  
  
Posted 3 years ago

I see it seems OK now... 🙂

  
  
Posted 3 years ago

OK, and what do you see now in the UI?

  
  
Posted 3 years ago

Yes looks great, thanks!
First thing though is I am going put it behind an nginx-proxy because there seems to be no ACL

  
  
Posted 3 years ago

Well, it was OK for a second, now it's not 😞

  
  
Posted 3 years ago

Does it still seem OK?

  
  
Posted 3 years ago

I'm not sure form the link I have here

  
  
Posted 3 years ago

Question, I see at the end of the docker-compose file:
networks:
backend:
driver: bridge
I want to change it to:

networks:
default:
external:
name: nginx-proxy

Will that break it?

  
  
Posted 3 years ago

Or maybe you just blocked access 😄

  
  
Posted 3 years ago

OK - please let me know if anything seems wrong again

  
  
Posted 3 years ago

Because I need it on the same network to go in the reverse proxy

  
  
Posted 3 years ago

Well, I must admit I didn't try it - but you're welcome to try and let us know :)

  
  
Posted 3 years ago

By the way, if you get that same UI error message (there might be an issue with migration detection), you can disable it in the server using the apiserver.elastic.upgrade_monitoring.v16_migration_verification flag set to false

  
  
Posted 3 years ago

Thanks!

  
  
Posted 3 years ago

Happy to help 🙂

  
  
Posted 3 years ago

Happend again after restarting the container.

Where does one add apiserver.elastic.upgrade_monitoring.v16_migration_verification flag set to false?

  
  
Posted 3 years ago

Nice 🙂

  
  
Posted 3 years ago

In the docker-compose.yml file, under the services.apiserver.environment section, add:
TRAINS__APISERVER__ELASTIC__UPGRADE_MONITORING__V16_MIGRATION_VERIFICATION: false

  
  
Posted 3 years ago

Needs quotes:
ERROR: The Compose file './docker-compose.yml' is invalid because:
services.apiserver.environment.TRAINS__APISERVER__ELASTIC__UPGRADE_MONITORING__V16_MIGRATION_VERIFICATION contains false, which is an invalid type, it should be a string, number, or a null

  
  
Posted 3 years ago

You can also put this configuration value in your opt/trains/config/apiserver.conf file, in which case the value is:
elastic.upgrade_monitoring.v16_migration_verification: false

  
  
Posted 3 years ago

Perhaps this is a result of your different network configuration? Trains Server's default CORS origins configuration is "*" by default

  
  
Posted 3 years ago

Investigating

  
  
Posted 3 years ago

Ok - how do I set the API server to a on the web-UI to a different path? Because the api-server needs to be also https, you can't mix calls

  
  
Posted 3 years ago

In the sub-domains section

  
  
Posted 3 years ago

You'll need to configure ELB and use sub-domains

  
  
Posted 3 years ago