Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Trains[Azure] Install - Azure Dependencies Not Latest. Trains Depends On Older Version Of Azure Python Sdk. My Project Already Has Dependency On The Latest Version. How Can This Be Resolved? Installing Collected Packages: Azure-Storage-Common, Azure-Stor

trains[azure] install - Azure dependencies not latest.
trains depends on older version of azure python sdk. My project already has dependency on the latest version. How can this be resolved?

Installing collected packages: azure-storage-common, azure-storage-blob
Attempting uninstall: azure-storage-blob
Found existing installation: azure-storage-blob 12.3.2
Uninstalling azure-storage-blob-12.3.2:
Successfully uninstalled azure-storage-blob-12.3.2
Successfully installed azure-storage-blob-2.1.0 azure-storage-common-2.1.0

  
  
Posted 4 years ago
Votes Newest

Answers 11


I just installed trains[azure]. Since all my data is on Azure. I don't know about StorageManager.

  
  
Posted 4 years ago

Many thanks!

  
  
Posted 4 years ago

trains[azure] give you the possibility to do the following:
from trains import StorageManager my_local_cached_file = StorageManager.get_local_copy('azure://bucket/folder/file.bin')This means you do not have to manually download stuff/ and maintain the cache local cache, the StorageManager will do that for you.
If you do no need that ability, no need to install the trains[azure] you can just install trains
Unfortunately, we haven't had the time to upgrade to the Azure storage v2 package (they changed the entire interface), and this is why the requirements collides with your installed packages. This is still on the to do list 🙂

  
  
Posted 4 years ago

Exactly 🙂
If you feel like PR-ing a fix, it will be greatly appreciated 🙂

  
  
Posted 4 years ago

I see that _AzureBlobServiceStorageDriver need to be updated. Anything else?

  
  
Posted 4 years ago

LazyLeopard18 are you using the StorageManager to access azure:// links?

  
  
Posted 4 years ago

I surely can, will let you know.

  
  
Posted 4 years ago

Also, each task might need its own configuration. Data are usually stored in multiple containers. Rather than a single configuration, there should be possibility to do it per task.

  
  
Posted 4 years ago

There already seems to be support for multiple containers in the code.
Is there an example to configure multiple storage accounts?

  
  
Posted 4 years ago

Check here:
https://github.com/allegroai/trains/blob/master/docs/trains.conf#L78

You can configure credentials based on the bucket name. Should work for Azure as well

  
  
Posted 4 years ago
806 Views
11 Answers
4 years ago
one year ago
Tags