Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello! I Am Trying To Upgrade From Trains Server 0.14.0 -> 0.14.1 (Docker Setup) I Have Followed The Upgrade Instructions On

Hello! I am trying to upgrade from trains server 0.14.0 -> 0.14.1 (docker setup)

I have followed the upgrade instructions on https://allegro.ai/docs/deploying_trains/trains_server_upgrading/

and the images I have now, based on the latest docker-compose.yml , are as follows:

REPOSITORY TAG DIGEST IMAGE ID CREATED SIZE redis 5.0 sha256:96bdb5e2984b15e3cf4de74077f650c911cb26ec0981e0772df35a1a5cb19798 975fe4b9f798 3 days ago 98.3MB allegroai/trains latest sha256:c2125920d32668f33de612c1cbbea9c6718c405e46a5713079fc3b84dfab4fdc 61697b982c70 4 weeks ago 673MB 5.6.16 sha256:9ffbb6d9d0f383d70b8249117e5758dcf9c628a5ab3a78fd6a520ef1d0f416a2 8b4495052160 13 months ago 529MB mongo 3.6.5 sha256:3e00936a4fbd17003cfd33ca808f03ada736134774bfbc3069d3757905a4a326 bbed8d0e01c1 22 months ago 368MB
I think these are the correct ones according to dockerhub.

However my trains dashboard is still prompting me to upgrade to 0.14.1.. Any way I can check the actual version from the dashboard ?
https://files.slack.com/files-pri/TT9ATQXJ5-F012CPA7LRJ/image.png
Thank you!

  
  
Posted 3 years ago
Votes Newest

Answers 20


Hi NutritiousBear41 ,

Are you getting the message from the task output? Something like:
TRAINS new package available: UPGRADE to v0.14.1 is recommended!

If so, you should upgrade trains python package, this message doesn't related to trains server but to the SDK.
You can do it with pip install -U trains

Can this be the issue?

  
  
Posted 3 years ago

A yellow bar that appears at the top prompting for upgrade - i will see if I can get a screenshot

  
  
Posted 3 years ago

Hi, no the message is on the Trains web dashboard

  
  
Posted 3 years ago

thanks CumbersomeCormorant74 that is what I was looking for

  
  
Posted 3 years ago

Apologies for the confusion - when I first saw the notification I thought I was still on 0.14.0 .. also under the profile tab it does not show the patch version

  
  
Posted 3 years ago

Do you still get the new version notification?

  
  
Posted 3 years ago

No problem. Glad it's working now

  
  
Posted 3 years ago

NutritiousBear41 - I would like to ask you to try the following:
Refresh the web page (control+F5). Check the browser's local storage: F12 -> Application/Storage -> Local Storage - and copy the values of "currentVersion" and "dismissedVersion" (if they exist)

  
  
Posted 3 years ago

NutritiousBear41 - I'm currently checking what can cause this. Will get back to you shortly

  
  
Posted 3 years ago

Haha it has appeared again

  
  
Posted 3 years ago

its kind of weird - if i close the tab and reload the localstorage gets set back to 0.14.0-305

  
  
Posted 3 years ago

if i refresh the currentVersion switched to the correct one (0.14.1-318)

  
  
Posted 3 years ago

NutritiousBear41 - If the problem still occurs - I would like to see i this is a caching issue. Can you please try the following:
Open developer tools (F12) and go to network tab Locate the last call to version.json (this occurs every few minutes so you should see it at the bottom) Right-click and select Edit and Resend On the right side - look at the Request Headers and remove the 2 lines starting with "If-Modified-Since:" and "If-None-Match:" (probably at the bottom) Press send

  
  
Posted 3 years ago

You know what let me see if I can reliably replicate the issue before you spend any more time on it - if I can I'll ping you back with a sequence to replicate

  
  
Posted 3 years ago

I am on Firefox 75.0 btw

  
  
Posted 3 years ago

the server is running on both port 8080 and port 80... (8080 redirects to 80 on the nat) ... accessing on :80 caching works fine ... accessing on :8080 is what does not update the version without a refresh ... but will check your instructions above later

  
  
Posted 3 years ago

ok - will have a look at it sometime this afternoon

  
  
Posted 3 years ago

ok so then I am on 0.14.1

  
  
Posted 3 years ago

I dismissed it and haven't seen it since

  
  
Posted 3 years ago

NutritiousBear41 - can you go to localhost:8080/version.json (or change to the relevant address of your web app) and see what it outputs?

  
  
Posted 3 years ago