Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hey, Guys! Trying To Make Clearml Use Git Repository Via Ssh. I Placed My Private Key With Correct Permissions To Agent Machine. When I Run My Code I Can Pass Ssh Url To My Repo Via Web Ui. It Works But I'D Like To Configure It In My Worker Configuration.

Hey, guys! Trying to make ClearML use git repository via ssh. I placed my private key with correct permissions to agent machine. When I run my code I can pass ssh URL to my repo via web UI. It works but I'd like to configure it in my worker configuration. Is there a place where to put it? I found agent.git_host parameter but I am a bit confused that a commentary says "Limit credentials to a single domain, for example: http://github.com ". Is it a correct place to put my URL ssh://my-repo.com/project.git to?

  
  
Posted one year ago
Votes Newest

Answers 7


@<1523701087100473344:profile|SuccessfulKoala55> I run it from local machine, that's right. When I run the task it says it can't clone repository. In the web UI on my task there's a REPOSITORY string. It's a correct ssh URL to my repo but it's missing git@ after ssh:// If I add the git part to it by editing the task and queuing again it works. In my config file I have option force_git_ssh_user: git enabled.

  
  
Posted one year ago

@<1523701087100473344:profile|SuccessfulKoala55> I reloaded agent couple of times, cleared cache and for some reason it works now! Anyways, thanks for your help!

  
  
Posted one year ago

Thank you, got it. I tried it because I couldn't figure out how to make auto-detection work. When I run a task from my local project folder (which is also a git repo) via Task.init it says that no repository was found. Also there is Task.create method which lets you pass git URL but I suspect the Task.init is more preferrable method

  
  
Posted one year ago

@<1523701087100473344:profile|SuccessfulKoala55>

from random import random
from clearml import Task, TaskTypes
import pandas as pd

task: Task = Task.init(
    project_name="My Project",
    task_name='Sample task',
    task_type=TaskTypes.inference
)

task.connect(args)
task.execute_remotely(queue_name="default")

value = random()
task.get_logger().report_single_value(name="sample_value", value=value)

df = pd.DataFrame.from_dict({'col_1': [3, 2, 1, 0], 'col_2': ['a', 'b', 'c', 'd']})
task.register_artifact("sample_artifact", df)
  
  
Posted one year ago

SuccessfulKoala55 So my question is how to setup auto-detection properly so worker knows what git repo to pull from

  
  
Posted one year ago

Do you have an example where it didn't work properly? The auto-detection is done when you run your code locally, on your own machine, by the SDK

  
  
Posted one year ago

Hi BoredBat47 , repository URL is always set on the task (auto-detected when you run your tasks and copied when you clone them) - why would you like to set this as a worker setting?

  
  
Posted one year ago
702 Views
7 Answers
one year ago
one year ago
Tags
Similar posts