Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Hi, I Am Using Two Different Environment For Mlops And Model Training. I Have Setup The Agent In The Training Environment. I Can Start The Queue Using Command 'Clearml-Agent Daemon --Queue Default' And That Works Perefectly, Whenever I Run A Pipeline Fro


I am using two different environment for mlops and model training. I have setup the agent in the training environment. I can start the queue using command 'clearml-agent daemon --queue default' and that works perefectly, whenever I run a pipeline from mlops it works fine.
But now I am trying to implement a startup script for 'clearml-agent daemon --queue default' so that whenever the training system starts/restarts the agent queue also starts. I used /etc/rc.local and added a single line to execute a single line script 'clearml-agent daemon --queue default'. But in this case queue starts but does not work properly, whenever I am using any nvidia tao command through pipeline I get a error "The input device is not a TTY".

However if I run clearml-agent daemon --queue default from terminal; then all tao commands from clearml pipeline works perfectly. DOnt understand why it does not work when setup as startup script using rc.local.

Posted one year ago
Votes Newest

Answers 2

Hi @<1561885927150718976:profile|ScantSeaurchin24> , why can't the agent stay up all the time?

Posted one year ago

I would assume you'll need the --detached flag for this?

Posted one year ago