Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
On The Machine With The Clearml Server, I Started The Http Pypi Server. But The Argument For Agent.Package_Manager Doesn'T Work For Me. Did I Write It Correctly In The Config? Some Lines Skipped!

On the machine with the clearml server, I started the http pypi server. But the argument for agent.package_manager doesn't work for me. Did I write it correctly in the config?
some lines skipped!

agent {
    package_manager: {
        type: pip,
        extra_index_url: ["
"],
        extra_pip_install_flags: ["--index-url=
", "--trusted-host=localhost"]

}

console:

Looking in indexes: 
, 

WARNING: The repository located at localhost is not a trusted or secure host and is being ignored. If this repository is available via HTTPS we recommend you use HTTPS instead, otherwise you may silence this warning and allow it anyway with '--trusted-host localhost'.
ERROR: Could not find a version that satisfies the requirement clearmllib==1.0.4 (from versions: none)
ERROR: No matching distribution found for clearmllib==1.0.4
  
  
Posted 5 months ago
Votes Newest

Answers 3


Hi @<1598487094601191424:profile|MysteriousCow84>
You should put it in the dedicated section:
None

  
  
Posted 5 months ago

Hi @<1523701205467926528:profile|AgitatedDove14>
My localhost is not secure and Ignored by clearm (pip in general).

agent.package_manager.extra_pip_install_flags.0 = --index-url= None
agent.package_manager.extra_pip_install_flags.1 = --trusted-host=localhost
I have these parameters in my agent settings

  
  
Posted 5 months ago

I resolve this problem

        extra_index_url: ["
"],
        extra_pip_install_flags: ["--trusted-host", "localhost"],

Thanks!

  
  
Posted 5 months ago
350 Views
3 Answers
5 months ago
5 months ago
Tags
Similar posts