Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello! I’M Trying To Re-Use Model, Which Is Already In Model Regystry And I Came Up With Two Ideas: Query Model And Connect It To The Task

Hello! I’m trying to re-use model, which is already in model regystry and I came up with two ideas:
Query model and connect it to the task

task.connect(model[0])

but in this case in model registry appears something like Imported by task_name and url of the model refers to local file, no to the remote storage.

Second, I tried to use model remote storage url to update task.update_output_model(model_path, ...) . The model with the same name appers in model storage, but MODEL URL in model description says None .
Whats the best way to re-use model? Is it possible to keep the same model, which is already in model registry, and attach it to the task? And let it appear in artifacts tab ?

  
  
Posted 3 months ago
Votes Newest

Answers 3


Do you mean that in the Model tab when you look into the model details the URL points to a local location (e.g. file:///mnt/something/model) ?

Exactly.

And your goal is to get a copy of that model (file) from your code, is that correct ?

See, it happens when I tried to connect existed model (in model registry, model is already uploaded to remote storage). I query this model and connect it to the task

model = InputModel.query_models(model_name=name
task.connect(model[0])

It creates Imported by SCRIPT_NAME record in model registry and in the Model tab, when I look into the model details, model_url refer to local file (file:///mnt/something/model)) for some reason

  
  
Posted 3 months ago

I resolved issue. Works like a charm. I disabled framework auto logging, and clearml does not try to store local model again.

  
  
Posted 3 months ago

Hi @<1523702307240284160:profile|TeenyBeetle18>

and url of the model refers to local file, no to the remote storage.

Do you mean that in the Model tab when you look into the model details the URL points to a local location (e.g. file:///mnt/something/model) ?
And your goal is to get a copy of that model (file) from your code, is that correct ?

  
  
Posted 3 months ago