Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hey Everyone, I Am Having Some Difficulties Passing Environment Variables On My Piepeline Components Running On Agents (

Hey everyone, I am having some difficulties passing environment variables on my piepeline components running on agents ( 1.6.1 ) without docker mode:

  • I set the env variables on the remote worker nodes
  • I also set the variable inside the clearml.conf file on my nodes like that on line 291:
# Apply top-level environment section from configuration into os.environ
    apply_environment: true
    # Top-level environment section is in the form of:
    environment {
        SLACK_WEBHOOK_URL: 

    }

But I systematically get a not found error when trying to access it through os.environ inside my pipeline components when running them whereas it works fine on local mode with the env variable set in the system.

Thanks in advance for any help you can provide!

  
  
Posted 2 months ago
Votes Newest

Answers 8


Okay, thanks for the pointer ❤

  
  
Posted 2 months ago

Oh, it's a little strange the comment lines about it were in the agent section

  
  
Posted 2 months ago

@<1523701087100473344:profile|SuccessfulKoala55> here you go

  
  
Posted 2 months ago

My agents are stared through systemd so maybe I should specify the env in the service file the clearml.conf file looks like it has a section to do it properly (see 2nd point above)

  
  
Posted 2 months ago

You can certainly do that in the clearml.conf file

  
  
Posted 2 months ago

That's since the control over whether to enable it or not are there - the example there simply illustrates how to use it

  
  
Posted 2 months ago

however, can you share the file itself? just to make sure this is in the correct place in the file

  
  
Posted 2 months ago

The issue is most likely due to the fact you've put the environment section under the agent section, while it should be top-level, not under any section:

# Top-level environment section is in the form of...
  
  
Posted 2 months ago