Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
I Have The Following Setup: Instance-1 With Clearml Server Hosted In Gcp, Visible Only Through Internal Network, Instance-2 With Clearml Agent Hosted In Gcp, Visible Only Through Internal Network, Reverse-Ngnix-Proxy Hosted In Gcp Acting As Interface Betw

I have the following setup:
instance-1 with clearml server hosted in GCP, visible only through internal network,
instance-2 with clearml agent hosted in GCP, visible only through internal network,
reverse-ngnix-proxy hosted in GCP acting as interface between clearml server and the world.

For the agent (on instance-2) clearml.conf uses internal network IPs for api_server, web_server and files_server.
For the client (my PC from which I wish to schedule a remote job) clearml.conf uses public URL (which will go through reverse proxy). Everything works correctly up to the point where the agent during the job execution tries to download a dataset by using public URL instead of the internal one. Where could it be getting the public URL from? Any proper way to force it to use the internal one (the one from its own clearml.conf)?

  
  
Posted 3 months ago
Votes Newest

Answers 8


Hi @<1631102016807768064:profile|ZanySealion18> , it's getting the URL since this URL is probably the URL used by the client when registering (and uploading) the dataset.

  
  
Posted 3 months ago

Additional info:
-Public URL uses HTTPS, internal traffic doesn't.
-clearml.storage fails while trying to fetch None ...

Meaning it just replaced the internal IP with the URL at some point for some reason, it doesn't exist in that form anywhere in any configs (http and public URL).

  
  
Posted 3 months ago

You can use the path substitution option (see here ) to make the code run by the agent will convert public URLs (i.e. with prefix None ) to internal URLs (i.e. replacing it with http://<my-ip> )

  
  
Posted 3 months ago

Doesn't work unfortunately 😕 Thanks either way!

  
  
Posted 3 months ago

Perfect, exactly what I needed, thanks!

  
  
Posted 3 months ago

It should be the same one

  
  
Posted 3 months ago

One more related question (I hope there's a similar solution), when I log images, they appear in the UI with http://<my-ip> so they are inaccessible (they should be translated to None . Is there any path_substitution variant for this scenario in the config? I can't seem to find it in the docs. Thanks!

  
  
Posted 3 months ago

I hacked around the solution by setting api.files_server for the agent to the public URL, but ideally I'd avoid going through reverse-proxy if there's some path_substitution equivalent for this. Thanks

  
  
Posted 3 months ago
213 Views
8 Answers
3 months ago
3 months ago
Tags