Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Remote Task Execution Fails On Self Hosted Clearml With:

Remote task execution fails on self hosted clearml with: fatal: could not read Username for ' None .<company>.com': terminal prompts disabled
I am launching remote task using devcontainer, which previously worked fine. Recently I encountered above issue which occurred only when there was catched repo in vsc-cache dir. For my colleague same commit/devcontainer worked as expected. I nailed down the problem to task configuration when running failing task task.export_task()["scripts"]["repository"] , this is git@<repo>.git. When I set repo origin as https, everything works fine.

  
  
Posted 3 months ago
Votes Newest

Answers 3


Deleting cached environment is also required, otherwise it will fail with the same error

  
  
Posted 3 months ago

Ok, this seems to fix it.

  
  
Posted 3 months ago

I have just encountered this. I believe it is because of the clearml-agent 1.7.0 release which added this as default: agent.enable_git_ask_pass: true

To fix, add in agent.enable_git_ask_pass: false to your config.

  
  
Posted 3 months ago
128 Views
3 Answers
3 months ago
3 months ago
Tags
Similar posts