Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
[Plot Not Showing Up In Ui When Setting File_Server To S3 Bucket] As A Somewhat In Depth Question, We’Ve Set Our Output_Uri And File_Server To An S3 Bucket To Prevent The Server From Running Out Of Space As Discussed In This Message. However, I’Ve Noticed

[Plot not showing up in UI when setting file_server to S3 bucket]
As a somewhat in depth question, we’ve set our output_uri and file_server to an S3 bucket to prevent the server from running out of space as discussed in this message.
However, I’ve noticed that now the plots get uploaded to S3, but they aren’t shown interactively in the Web UI anymore. Is there any particular reason?
I create them with Matplotlib and also tried reporting the figure explicitly - in the latter case the figure shows up statically in Debug Samples:
fig = plt.figure() ... logger.report_matplotlib_figure("Title", "Series", iteration=1, figure=fig) # Tried with and without plt.savefig("fig.png")Do interactive figures not work with S3? (Would actually be ok.)

  
  
Posted one year ago
Votes Newest

Answers 4


SuccessfulKoala55 just in case you have any more thoughts, but we could also continue as is 😊

  
  
Posted one year ago

ScantChimpanzee51 , one thought - If you take the s3 link used by the UI and try to download it using the ClearML SDK, does that workl?

  
  
Posted one year ago

Hi ScantChimpanzee51 , these should work, of course
Did you add your S3 credentials to the ClearML WebApp in the profile section?

  
  
Posted one year ago

Yes, when the WebUI prompted me for them. They also seem to work since images in Debug Samples (also in S3) show up after I entered them.
Also, I can see that the plot is also saved in Debug Samples after explicit reporting, even though I don’t set report_interactive=False

  
  
Posted one year ago
676 Views
4 Answers
one year ago
one year ago
Tags