Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi. Here'S A Question For

Hi. Here's a question for uploading models.
calling PipelineDecorator.upload_model(model_name, model_path) in a pipeline component logs
clearml.model - INFO - No output storage destination defined, registering local model /root/.clearml/venvs-builds.1/3.7/code/runs/train/out/weights/best.ptI configured clearml.conf and have no problem uploading something to my s3 using StorageManager
so. How can I configure the output storage destination for a pipeline component?

  
  
Posted one year ago
Votes Newest

Answers 4


Hi FancyWhale93 , in your clear.conf configure default output uri, you can specify the file server as default, or any object storage:
https://github.com/allegroai/clearml-agent/blob/9054ea37c2ef9152f8eca18ee4173893784c5f95/docs/clearml.conf#L409

  
  
Posted one year ago

Great! setting the default_output_uri worked!
Thank you.

  
  
Posted one year ago

Thanks for the reply CostlyOstrich36
The local machine & agent machine has the same clearml.conf . As I sad, storing something via StorageManager has no problem on both side.
But PipelineDecorator.upload_model(model_name, model_path) doesn't work on both side.

  
  
Posted one year ago

FancyWhale93 , you need to make the same configuration changes to ~/clearml.conf file on the machine running clearml-agent that is running the pipeline steps

  
  
Posted one year ago
609 Views
4 Answers
one year ago
one year ago
Tags