Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hey,

Hey,
I have my clearml server set up on my local machine , however I want to try clearml- serving on this machine as well;
But here's the issue:
When I run the docker-compose file while running the server the clearml-inferencing container seems to be on the same port as the server? Any workaround for this? Can I change ports and where exactly ?

  
  
Posted one year ago
Votes Newest

Answers 26


can you do docker ps to check if there are running containers that already bind the port ?

  
  
Posted one year ago

hi WickedElephant66
I have the same issue, but port is not the only problem
https://clearml.slack.com/archives/CTK20V944/p1656446563854059

  
  
Posted one year ago

I'm running the clearml server on my machine, self hosted

  
  
Posted one year ago

TenderCoyote78 i pm you to avoid overfilling the thread here

  
  
Posted one year ago

I'm not, not sure about WickedElephant66 / DefiantHippopotamus88

  
  
Posted one year ago

Let's maybe join our effort to get local deployment?

  
  
Posted one year ago

can you share your logs ?

  
  
Posted one year ago

hey Martin,
DefiantHippopotamus88 joined the thread. He faced the same issue in the thread you sent
https://clearml.slack.com/archives/CTK20V944/p1656537337804619?thread_ts=1656446563.854059&cid=CTK20V944

  
  
Posted one year ago

AgitatedDove14 are you using wsl setup?

  
  
Posted one year ago

at least no more auth errors

  
  
Posted one year ago

Wdym?

  
  
Posted one year ago

Or is something wrong here

  
  
Posted one year ago

image

  
  
Posted one year ago

Im using the clearml-serving for repo and running the docker-compose file there to set it tip ,
But im also running the clearml server on my machine self - hosted

  
  
Posted one year ago

Hey,
So I did change the host port on the docker -compose.yml file, here's the weird error:
Why is the url being parsed with “”
I have renamed example. en v to just .env so that docker -compose can recognise the env variables(—env-file never works for me)

  
  
Posted one year ago

Removing the “” in my env file gives me a timeout issue

  
  
Posted one year ago

SweetBadger76 I'm following the docs, is this the expected output?

  
  
Posted one year ago

DefiantHippopotamus88 did you get it working?

  
  
Posted one year ago

when you spin a container , you map a host port with a container port using -p parameter
docker run -v ~/clearml.conf:/root/clearml.conf -p 8080:8080 -e CLEARML_SERVING_TASK_ID =<service_id> -e CLEARML_SERVING_POLL_FREQ =5 clearml-serving-inference:latest
Here you map your computer's port 8080 with the container port 8080. If your 8080 port is already used, you can use another, using for example -p 8081:8080

  
  
Posted one year ago

I'm facing the issue during the initial set up of clearml serving - i.e the step where you use docker-compose to launch the serving containers

  
  
Posted one year ago

AgitatedDove14 Doesn't look like the same error as that thread.

  
  
Posted one year ago

Here's what I get for the initial set up stage of clearml-serving

  
  
Posted one year ago

So I'd have to make edits to the docker-compose file for clearml-serving; there would not be any issues arising due to that right?

  
  
Posted one year ago

Oh okay

  
  
Posted one year ago

it worked for me with one docker-compose for all

  
  
Posted one year ago
528 Views
26 Answers
one year ago
6 days ago
Tags
Similar posts