Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello!

Hello! 🙂
I have my own minio setup and everything seems to work fine, however in clearml when I press to download an artifact with an url starting with s3://myminio.server/something will open with http resulting in 400 Bad Request The plain HTTP request was sent to HTTPS port nginx/1.21.6 for me. When I manually change to https it works. Any way to fix this?

  
  
Posted one year ago
Votes Newest

Answers 4


Yes, that works fine. Just the http vs https was the problem. The UI will automatically change s3://<minio-address>:<port> to http://<minio-address>:<port> in http://myclearmlserver.org/settings/webapp-configuration . However what is needed for me is https://<minio-address>:<port>

  
  
Posted one year ago

Hmm, in the credentials popup there should be a "secure connect" checkbox, it tells it to use https instead of http. Can you verify?

  
  
Posted one year ago

Hi ReassuredTiger98
To separate between minio and S3 we use:
s3://bucket/file for AWS S3 service and s3://server :port/bucket/file for minio.
this means if your S3 links would have been s3://<minio-address>:<port>/bucket/file.bin the UI would have popped the cred window.
Make sense ?

  
  
Posted one year ago

To answer my own question: In the WebUI where one inputs the credentials, use https for the host instead of the auto-added http

  
  
Posted one year ago
482 Views
4 Answers
one year ago
one year ago
Tags