Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello, I’M Trying To Log (Via

Hello, I’m trying to log (via task.connect() ) a dictionary of the exp parameters. As I understood it, ClearML supports only builtin types, but I’m getting this message saying that a parameter is skipped:
clearml.Task - WARNING - Skipping parameter: a/b/c/d/e[tuple], only builtin types are supported (list, tuple, dict, int, float, str, NoneType)I’m sure that the value is a tuple like this (0, 100, None) . I’m on v1.3.1-169. thank you πŸ™‚

  
  
Posted 2 years ago
Votes Newest

Answers 18


Hi RattyLouse61 , what's the SDK version?

  
  
Posted 2 years ago

Hey CostlyOstrich36 , the parameter I’m trying to log is a tuple (0, 100, None) and it’s stored in a nested dictionary. E.g.
{"a": {"b": {"c": (0, 100, None)}}}

  
  
Posted 2 years ago

RattyLouse61 I meant the version pf the clearml python package you're using when running the code, just do pip show clearml

  
  
Posted 2 years ago

SuccessfulKoala55 this is what I see on the Profile page:
WebApp: 1.3.1-169 β€’ Server: 1.3.1-169 β€’ API: 2.17

  
  
Posted 2 years ago

if this is a bug, I can raise an Issue in github and provide a snippet of code to reproduce it

  
  
Posted 2 years ago

Let me take a look πŸ™‚

  
  
Posted 2 years ago

ops. 1.1.6

  
  
Posted 2 years ago

I played a bit with it, it looks like it's caused by the 'None' in the dict. I think it would be nice if you opened a github issue πŸ™‚

As a temporary solution you can use the following method - Task.connect_configuration()

  
  
Posted 2 years ago

RattyLouse61 , one of the guys tells me that a fix will be pushed soon πŸ™‚

  
  
Posted 2 years ago

Can you try upgrading and see what happens?

  
  
Posted 2 years ago

upgraded to 1.3.2

  
  
Posted 2 years ago

CostlyOstrich36 thank you πŸ™‚ I suppose the issues isn’t necessary if someone is already working on a fix?

  
  
Posted 2 years ago

SuccessfulKoala55 is this fixed in this release https://clearml.slack.com/archives/C03E7MNDG3C/p1651763847469039 ?

  
  
Posted one year ago

RattyLouse61 , yep πŸ™‚

  
  
Posted 2 years ago

Hi RattyLouse61 ,

Do you have an example of the parameters you're trying to connect?

  
  
Posted 2 years ago

In [6]: type(conf["a"]["b"]["c"]["d"]) Out [6]: tuple

  
  
Posted 2 years ago

getting the same behaviour

  
  
Posted 2 years ago

I think so

  
  
Posted one year ago
545 Views
18 Answers
2 years ago
one year ago
Tags