Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi All, I Have A Problem With Setting Up An Agent. I Set Up Local Server On Ubuntu Behind Proxy, It Seems To Work Correctly. I Can Access Web Ui And Set Up Agent On A Windows Machine Just Fine, But When I Try To Set Up Agent On Any Linux Machine It Fails

Hi all, I have a problem with setting up an agent. I set up local server on ubuntu behind proxy, it seems to work correctly. I can access web UI and set up agent on a windows machine just fine, but when I try to set up agent on any linux machine it fails to verify credentials. I can ping apiserver with curl and it returns some json correctly but when I try to use clearml-agent init it doesn't work. Any ideas how to fix it, or why it happens?

  
  
Posted 2 years ago
Votes Newest

Answers 6


Sure, it's just this
Verifying credentials ... Error: could not verify credentials: key=

  
  
Posted 2 years ago

Are you sure you pasted the credentials correctly? Does it give you feedback on which key/secret you used during the process? Which version of ClearML-Agent are you on?

  
  
Posted 2 years ago

Hi, can you give the error that is printed out?

  
  
Posted 2 years ago

CostlyOstrich36 Sorry for late reply, I copied clearml.conf from windows machine to linux machine, changed credentials and added verify_certificate: False as you said. Then I started agent with this command:
clearml-agent daemon --queue default --foregroundIt doesn't produce any output and machine also doesn't appear in a worker pool, but in settings/workspace on provided credentials it changes last used and worker/ip fields

  
  
Posted 2 years ago

DefiantLobster38 , please try the following - Change the verify_certificate to False
https://github.com/allegroai/clearml/blob/aa4e5ea7454e8f15b99bb2c77c4599fac2373c9d/docs/clearml.conf#L16
Tell me if it helps 🙂

  
  
Posted 2 years ago

Yes, when I provide the same credentials to a windows machine it works just fine. I don't know, the latest one probably, I install it with pip

  
  
Posted 2 years ago
518 Views
6 Answers
2 years ago
one year ago
Tags
Similar posts