Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Can I Prevent

Can I prevent
torch.save()from automatically uploading the model and use
task.update_output_model(model_path=best_model_path)at the end to upload the best model?

  
  
Posted 2 years ago
Votes Newest

Answers 7


however, this will also turn off metrics 😞

  
  
Posted 2 years ago

thanks

  
  
Posted 2 years ago

however, this will also turn off metrics 

For the sake of future readers, let me clarify on this one, turning it off auto_connect_frameworks={'pytorch': False} only effects the auto logging of torch.save/load
(side note: the reason is pytorch does not have built in metric reporting, i.e. it is usually done manually and these days most probably with tensorboard, for example lightning / ignite will use tensorboard as default metric reporting),

  
  
Posted 2 years ago

RobustRat47 it seems I was mistaken - for anything other than tensorboard and matplotlib, it only controls models binding

  
  
Posted 2 years ago

it would be useful to have some control over this if possible 🙂

  
  
Posted 2 years ago

oh okay

  
  
Posted 2 years ago

When initializing your task, simply make sure to turn off the auto-connect for pytorch, using Task.init(..., auto_connect_frameworks={'pytorch': False})

  
  
Posted 2 years ago