Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
I Keep Facing This Issue. I'M Trying To Set Up My Own Clearml Server Using This Tutorial.

I keep facing this issue. I'm trying to set up my own clearml server using this tutorial. https://allegro.ai/clearml/docs/docs/deploying_clearml/clearml_server_linux_mac.html

Only problem is, it won't run properly. I export host ip as the ip that the network gave me. but when I try to access server, it doesn't run properly

  
  
Posted 2 years ago
Votes Newest

Answers 19


There's a whole task bar on the left in the server. I only get this page when i use the ip 0.0.0.0

  
  
Posted 2 years ago

I think maybe it does this because of cache or something. Maybe it keeps a record of an older login and when you restart the server, it keeps trying to use the older details maybe

  
  
Posted 2 years ago

I feel like they need to add this in the documentation 😕

  
  
Posted 2 years ago

VexedCat68 , what errors are you getting? What exactly is not working, the webserver or apiserver? Are you trying to access the server from the machine you set it up on or remotely?

  
  
Posted 2 years ago

Big thank you though.

  
  
Posted 2 years ago

VexedCat68 , It appears to be a bug of sorts, we'll sort it out 🙂

  
  
Posted 2 years ago

wrong image. lemme upload the correct one.

  
  
Posted 2 years ago

let me check

  
  
Posted 2 years ago

Ok this worked. Thank you.

  
  
Posted 2 years ago

VexedCat68 , can you try accessing it as
192.168.15.118:8080/login first?

  
  
Posted 2 years ago

Also, is clearml open source and accepting contributions or is it just a limited team working on it? Sorry for an off topic question.

  
  
Posted 2 years ago

When I try to access the server with the IP I set as CLEARML_HOST_IP, it looks like this. I set that IP to the ip assigned to me by the network

  
  
Posted 2 years ago

VexedCat68 this likely happens since you already have a token for another ClearML server (perhaps another server you've set up?). The correct fix it to either make sure you clear your browser's cookies, or (if you have more than one server set up), make sure each server uses a different cookie name.

  
  
Posted 2 years ago

I think I get what you're saying yeah. I don't know how I would give each server a different cookie name. I can see this problem being resolved by clearing cookies or manually entering /login at the end of the url

  
  
Posted 2 years ago

when you connect to the server properly, you're able to see the dashboard like this with menu options on the side.

  
  
Posted 2 years ago

You can see there's no task bar on the left. basically I can't get any credentials to the server or check queues or anything.

  
  
Posted 2 years ago

Shouldn't I get redirected to the login page if i'm not logged in instead of the dashboard? 😞

  
  
Posted 2 years ago

Changing cookie name is part of server's basic configuration in the apiserver.conf file, see here https://github.com/allegroai/clearml-server/blob/a64c4d264d00eadd2d11818b37151d3cc6266d99/apiserver/config/default/apiserver.conf#L72

  
  
Posted 2 years ago

I've been having this issue for a while now :((

  
  
Posted 2 years ago
407 Views
19 Answers
2 years ago
11 months ago
Tags