Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, We'Re Hosting Clearml On Our K8S Cluster, And I'M Running Into Problems With It... I'Ve Set It Up In A Subdomain Way - App/Files/Api.Clearml.Mydomain... But I Have Some Issues With The Ssl Certificate. When I Try Running

Hi,
We're hosting ClearML on our k8s cluster, and I'm running into problems with it...
I've set it up in a subdomain way - app/files/api.clearml.mydomain... but I have some issues with the SSL certificate.
When I try running clearml-init - it does not manage to verify the credentials: Error: could not verify credentials: key=<key> secret =<secret>

How can I solve it? or at least see what the error is?

  
  
Posted 2 years ago
Votes Newest

Answers 15


It might do the same ?!

  
  
Posted 2 years ago

clearml.conf is the file that 

clearml-init

 suppose to create, right?

Correct, specifically ~/clearml.conf

  
  
Posted 2 years ago

Hi PleasantGiraffe85 , just to get some more info; what version of chart are you using? Did you enabled ingress?

  
  
Posted 2 years ago

BTW: see if this works:
$ CLEARML_API_HOST_VERIFY_CERT=0 clearml-init

  
  
Posted 2 years ago

😄 ok ok, I'll see if it works then

  
  
Posted 2 years ago

Yey!

  
  
Posted 2 years ago

or point to the self signed certificate:
export REQUESTS_CA_BUNDLE=/path/to/your/certificate.pem

  
  
Posted 2 years ago

Ingress is enabled - I can't control the ports in Ingress, so I had to use the subdomain method.

  
  
Posted 2 years ago

clearml.conf is the file that clearml-init suppose to create, right?

  
  
Posted 2 years ago

The manual clearml.conf worked 🙂 thanks for this!!

  
  
Posted 2 years ago

PleasantGiraffe85 you can disable the SSL verification on the client end:
https://github.com/allegroai/clearml-agent/blob/21c4857795e6392a848b296ceb5480aca5f98e4b/docs/clearml.conf#L12
Basically you can just manually create the clearml.comf with only the following:
api { api_server: web_server: files_server: `
credentials {"access_key": "EGRTCO8JMSIGI6S39GTP43NFWXDQOW", "secret_key": "x!XTov_G-#vspE*Y(h$Anm&DIc5Ou-F)jsl$PdOyj5wG1&E!Z8"}

# verify host ssl certificate, set to False only if you have a very good reason
verify_certificate: True

} `

  
  
Posted 2 years ago

I did not use Chart nor Helm.
We just don't have enough credentials here to use those. I had to install everything manually, service by service.

  
  
Posted 2 years ago

Good question 🙂
from clearml import Task Task.init('examples', 'test')

  
  
Posted 2 years ago

Thanks! And how can I validate it? that it properly connects?

  
  
Posted 2 years ago

got the point, ty; in that case let other guys chime in too 🙂

  
  
Posted 2 years ago
500 Views
15 Answers
2 years ago
one year ago
Tags