Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, I Just Updated Clearml Server 1.0 Using

Hi, I just updated clearml server 1.0 using docker-compose down & docker-compose pull & docker-compose up -d , it worked ant it looks amazing!
I found two problems though:

I cannot log out: I am getting a notification with error:Logout Failed Unable to find endpoint for name login.logout and version 2.132. After clearing the site cookies/cache to force logout, I can log in without password, while I was requiring auth via static accounts in /opt/clearml/config/apiserver.conf . This is a big problem, any idea how to fix?

  
  
Posted 3 years ago
Votes Newest

Answers 18


Hi JitteryCoyote63 ,
The logout issue has been reported and will be patched and released as v1.0.1 in the next few days.
As for the static accounts support, this was actually tested and is working for me - can you provide more info? Sometimes, this might indicate the WebUI fails to connect to the API server and (incorretcly) assumed it's in the "free access" mode, but when you try to actually log in with some user name you'll get an error - can you actually log in in this free access mode?

  
  
Posted 3 years ago

Hi SuccessfulKoala55 , How can I now if I log in in this free access mode? I assume it is since in the login page I only see login field, not password field

  
  
Posted 3 years ago

The only thing that changed is the new auth.fixed_users.pass_hashed field, that I don’t have in my config file

  
  
Posted 3 years ago

I added the pass_hashed and restarted the server, still get the same problem

  
  
Posted 3 years ago

Well, basic.enabled: false means the server is indeed not configured for user/password access... 😞

  
  
Posted 3 years ago

The easiest was is to call the server's /login.supported_modes endpooint

  
  
Posted 3 years ago

Thanks for the help SuccessfulKoala55 , the problem was solved by updating the docker-compose file to the latest version in the repo: https://github.com/allegroai/clearml-server/blob/master/docker/docker-compose.yml
Make sure to do docker-compose down & docker-compose up -d afterwards, and not docker-compose restart

  
  
Posted 3 years ago

Also, the apiserver container log should also shed light on this matter as it lists all the configuration files it reads

  
  
Posted 3 years ago

Should work now as well - wanna share your docker-compose.yml ?

  
  
Posted 3 years ago

The access mode is actually not related to the cookies themselves (wouldn't be much of a secure mode if it was), but depends on server configuration

  
  
Posted 3 years ago

How do you configure the server? Did you use an apiserver.conf file with the fixed users passwords?

  
  
Posted 3 years ago

This is what I get, when I am connected and when I am logged out (by clearing cache/cookies)

  
  
Posted 3 years ago

so in your browser, do http://<server-address>:8008/login.supported_modes

  
  
Posted 3 years ago

under /opt/clearml/config/apiserver.conf

  
  
Posted 3 years ago

It worked with clearml server 0.17

  
  
Posted 3 years ago

Yeah, that shouldn't affect you

  
  
Posted 3 years ago

yes exactly

  
  
Posted 3 years ago
626 Views
18 Answers
3 years ago
one year ago
Tags