Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hey! I'M Having A Weird Issue When I Run Pip Freeze Locally It'S Showing Version "Clearml==0.17.5Rc6" But When I Initiate The Task It'S Always Starting With "Clearml==0.17.2" - This Version Isn'T Accepting Tags Through The Code Etc. (I'M Manually Fixing I

Hey!
I'm having a weird issue when I run pip freeze locally it's showing version "clearml==0.17.5rc6" but when I initiate the task it's always starting with "clearml==0.17.2" - this version isn't accepting tags through the code etc. (I'm manually fixing in the UI). Just wondering what I'm doing wrong.

  
  
Posted 3 years ago
Votes Newest

Answers 18


So where is it coming from ?

  
  
Posted 3 years ago

It seems stuck somewhere in the python path... Can you check in runtime what's os.environ['PYTHONPATH']

  
  
Posted 3 years ago

Checked and I actually only have 0.17.5rc6 installed in any env. No v0.17.2 in the system packages

  
  
Posted 3 years ago

SmallBluewhale13
And the Task.init registers 0.17.2 , even though it prints (while running the same code from the same venv) 0.17.2 ?

  
  
Posted 3 years ago

SmallBluewhale13 in your code what are you getting when you print the version:
from clearml import __version__ print(__version__)

  
  
Posted 3 years ago

Yes , the installed packages shows as 0.17.2 and the print is 0.17.5rc6

  
  
Posted 3 years ago

I'll try uninstalling and see if that clears it up

  
  
Posted 3 years ago

I'm getting: "0.17.5rc6"

  
  
Posted 3 years ago

nope inside terminal

  
  
Posted 3 years ago

I'm using pyenv if that could be the issue?

  
  
Posted 3 years ago

I'm glad it worked out, thanks SmallBluewhale13 🙂

  
  
Posted 3 years ago

ended up updating to the latest release and this has fixed the issue

  
  
Posted 3 years ago

Hmm that is odd, could it be you are changing the sys.path ?
(What I'm assuming is happening is that it detects the packages in the PYTHONPATH and for some reason the order is different so it finds the "system" package before the "venv" package, hence the incorrect version)

  
  
Posted 3 years ago

and you have clearml v0.17.2 installed on the "system" packages level, and 0.17.5rc6 installed inside the pyenv venv ?

  
  
Posted 3 years ago

I have no idea, that's my question. In the above I assumed that i must have had another version on my system python. But upon checking I don't

  
  
Posted 3 years ago

Hmmm, are you running inside pycharm, or similar ?

  
  
Posted 3 years ago

TenseOstrich47 tagging for viz

  
  
Posted 3 years ago

Thanks for the help, wish i knew what is was but I guess it will be one of those things 🙈

  
  
Posted 3 years ago
518 Views
18 Answers
3 years ago
one year ago
Tags