Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, I Can'T Seem To Set A Password To Clearml, Anyone Seems To Be Able To Just Enter The Username And They Can Enter That Username'S Workspace.

Hi, i can't seem to set a password to clearml, anyone seems to be able to just enter the username and they can enter that username's workspace.

  
  
Posted 3 years ago
Votes Newest

Answers 6


It's a local deployment. I was only presented with username without a need to enter passwords. When I'm in, I don't see an option in my profile to set a password as well. Neither is there integration with ldap for example.

  
  
Posted 3 years ago

Hi SubstantialElk6 , what ClearML Server type are you using? Is this a local deployment, or the AWS AMI? How are you trying to set the password?

  
  
Posted 3 years ago

NastyFox63 you're absolutely correct - there was some mixup in the docs - the link is here: https://allegro.ai/clearml/docs/docs/deploying_clearml/clearml_server_config.html#web-login-authentication
I'll make sure to update the docs.

  
  
Posted 3 years ago

thanks for doing that and thanks for your work on the project 🙂

  
  
Posted 3 years ago

hi SubstantialElk6 , not sure if you were successful on this but i struggled with it as well, and it looks like the information is not in the linked document anymore.

in the end i realized that i needed to download apiserver.conf from the clearml-server repo ( https://github.com/allegroai/clearml-server/blob/master/apiserver/config/default/apiserver.conf ) and then add a user/pass for myself (starting at line 82).

  
  
Posted 3 years ago
530 Views
6 Answers
3 years ago
one year ago
Tags