Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Currently, To Provide Ssh Access To The Docker Images For A Task,

Currently, to provide SSH access to the docker images for a task, .ssh is mounted into the docker. Wouldn't a solution like this https://gist.github.com/d11wtq/8699521 be more elegant?
Probably nothing high priority for clearml, but in general this would avoid mounting the (private) keys into the docker container.

  
  
Posted 3 years ago
Votes Newest

Answers 13


By default SSH server is not running in a lot of scenarios (k8s for example, Windows, MacOS)...

  
  
Posted 3 years ago

Is there a way for me to configure/add the run arguments for the docker run call?

  
  
Posted 3 years ago

Perfect, thanks! Only issue that is left, is that it seems like .ssh is used even when I provideSSH_AUTH_SOCK. I created an issue here: https://github.com/allegroai/clearml-agent/issues/45

  
  
Posted 3 years ago

What exactly do you mean by docker run permissions?

https://docs.docker.com/engine/install/linux-postinstall/

  
  
Posted 3 years ago

Sure, ReassuredTiger98 just add them after the docker image in the "Base Docker image" section under the execution Tab. The same applies for setting it from code.
example:
nvcr.io/nvidia/tensorflow:20.11-tf2-py3 -v /mnt/data:/mnt/dataYou can also always force extra docker run arguments by changing the clearml.conf on the agent itself:
https://github.com/allegroai/clearml-agent/blob/822984301889327ae1a703ffdc56470ad006a951/docs/clearml.conf#L121

  
  
Posted 3 years ago

The .ssh is mounted, but the owner is my local user,

sudo -H clearml-agent ...to allow sudo to access home

  
  
Posted 3 years ago

Yes, but this seems pretty reasonable to assume imo.

  
  
Posted 3 years ago

Okay, I didn't know that. I just saw that VSCode seems to use a similar setup for their docker devcontainers.

  
  
Posted 3 years ago

I am getting permission errors when I try to use the clearml-agent with docker containers. The .ssh is mounted, but the owner is my local user, so the docker containers root does not seem to have the correct permissions.

  
  
Posted 3 years ago

What exactly do you mean by docker run permissions?

  
  
Posted 3 years ago

Hmm you either need to run with SUDO or make sure the running user has docker run permissions

  
  
Posted 3 years ago

I just checked and my user is part of the docker group.

  
  
Posted 3 years ago

I think for it to work you have to have ssh running on the host machine (the socket client itself), no?

  
  
Posted 3 years ago