Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Agent-Services: Networks: - Backend Container_Name: Trains-Agent-Services Image: Allegroai/Trains-Agent-Services:Latest Restart: Unless-Stopped Privileged: True Environment: Trains_Host_Ip: ${Trains_Host_Ip} Train

agent-services: networks: - backend container_name: trains-agent-services image: allegroai/trains-agent-services:latest restart: unless-stopped privileged: true environment: TRAINS_HOST_IP: ${TRAINS_HOST_IP} TRAINS_WEB_HOST: ${TRAINS_WEB_HOST:-} TRAINS_API_HOST: TRAINS_FILES_HOST: ${TRAINS_FILES_HOST:-} TRAINS_API_ACCESS_KEY: ${TRAINS_API_ACCESS_KEY:-} TRAINS_API_SECRET_KEY: ${TRAINS_API_SECRET_KEY:-} TRAINS_AGENT_GIT_USER: ${TRAINS_AGENT_GIT_USER} TRAINS_AGENT_GIT_PASS: ${TRAINS_AGENT_GIT_PASS} TRAINS_AGENT_UPDATE_VERSION: ${TRAINS_AGENT_UPDATE_VERSION:->=0.15.0} TRAINS_AGENT_DEFAULT_BASE_DOCKER: "ubuntu:18.04" AWS_ACCESS_KEY_ID: ${AWS_ACCESS_KEY_ID:-} AWS_SECRET_ACCESS_KEY: ${AWS_SECRET_ACCESS_KEY:-} AWS_DEFAULT_REGION: ${AWS_DEFAULT_REGION:-} AZURE_STORAGE_ACCOUNT: ${AZURE_STORAGE_ACCOUNT:-} AZURE_STORAGE_KEY: ${AZURE_STORAGE_KEY:-} GOOGLE_APPLICATION_CREDENTIALS: ${GOOGLE_APPLICATION_CREDENTIALS:-} TRAINS_WORKER_ID: "trains-services" TRAINS_AGENT_DOCKER_HOST_MOUNT: "/opt/trains/agent:/root/.trains" volumes: - /var/run/docker.sock:/var/run/docker.sock - /opt/clearml/agent:/root/.trains depends_on: - apiserver

  
  
Posted 3 years ago
Votes Newest

Answers 2


Hey GreasyPenguin14 ,
The docker-compose.yml and this section specifically were updated.
So first please try again with the new version 🙂
Second - this error seems a bit odd, which version of docker-compose are you using?
You can check this using: docker-compose --version

  
  
Posted 3 years ago

Updated docker-compose from 1.17 to 1.24.1 and using the latest docker-compose.yml solves the issue, thanks

  
  
Posted 3 years ago
644 Views
2 Answers
3 years ago
one year ago
Tags