Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Guess We'Re Back To Basics How Do I Report A Single Scalar With No Iteration Dimension - Something I Can Put As One Of The Columns In The Experiments Table?

Guess we're back to basics

How do I report a single scalar with no iteration dimension - something I can put as one of the columns in the experiments table?

  
  
Posted 3 years ago
Votes Newest

Answers 22


You can just use report_scalar:
from trains import Logger Logger.current_logger().report_scalar("title", "series", iteration=0, value=1337)Then you can select it as a metric in the experiment tale.

  
  
Posted 3 years ago

By the examples I figured out this ould appear as a scatter plot with X and Y axis and one point only.. Does it avoid that?

  
  
Posted 3 years ago

I'm using iteration = 0 at the moment, and I "choose" the max and it shows as a column... But the column is not the scalar name (because it cuts it and puts the > sign to signal max).

For the sake of comparing and sorting, it makes sense to log a scalar with a given name without the iteration dimension

  
  
Posted 3 years ago

This is what I'm seeing the > is the title - series relation. I'm not 100% clear why the iteration is a problem, could you elaborate?

  
  
Posted 3 years ago

Yes, I have a metric I want to monitor so I will be able to sort my experiments by it. It is logged in this manner

logger.report_scalar(title='Mean Top 4 Accuracy', series=ARGS.model, iteration=0, value=results['top_4_acc'].mean())
When looking at my dashboard this is how it looks

  
  
Posted 3 years ago

That is not very informative

  
  
Posted 3 years ago

what's the value of ARGS.model? is it "4"?

  
  
Posted 3 years ago

it is a model name

  
  
Posted 3 years ago

only string

  
  
Posted 3 years ago

doesn't contain the number 4

  
  
Posted 3 years ago

this is the selection from the column setting menu

  
  
Posted 3 years ago

I...Think it's a UI bug? I'll confirm 🙂

  
  
Posted 3 years ago

Could be, my message is that in general, the ability to attach a named scalar (without iteration/series dimension) to an experiment is valuable and basic when looking to track a metric over different experiments

  
  
Posted 3 years ago

moreover I think I found a bug

  
  
Posted 3 years ago

see gif:

  
  
Posted 3 years ago

WackyRabbit7 How do I reproduce it ?

  
  
Posted 3 years ago

AgitatedDove14 all I did was to cerate this metric as "last" and then turned on the "max" and "min" and then turned them off

I can't reproduce it now but:
I restarted the services and it didn't help I deleted the columns, and created them again after a while and it helped

  
  
Posted 3 years ago

It would, but it would get the trick. you can update the iteration 0 value and you'll be able to see it in the table. or do you mean you ONLY want to see it in the table and not in the scalars tab?

  
  
Posted 3 years ago

image

  
  
Posted 3 years ago

image

  
  
Posted 3 years ago

Nope

  
  
Posted 3 years ago

Just to make sure, if you change the title to "mean top four accuracy" it should work OK

  
  
Posted 3 years ago
547 Views
22 Answers
3 years ago
8 days ago
Tags