Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, I'M Trying To Set Up My Trains-Server And I'M Getting The Following:

Hi, I'm trying to set up my trains-server and I'm getting the following:
(base) emilio@unicorn:~$ docker-compose -f /opt/trains/docker-compose.yml up -d ERROR: Invalid interpolation format for "environment" option in service "agent-services": "${AZURE_STORAGE_KEY:-}"

  
  
Posted 3 years ago
Votes Newest

Answers 15


AgitatedDove14 yeah it should be..

  
  
Posted 3 years ago

ElegantCoyote26 could you upgrade the docker-compose ?

  
  
Posted 3 years ago

Yey!

  
  
Posted 3 years ago

(base) emilio@unicorn:~$ docker version Client: Docker Engine - Community Version: 19.03.13 API version: 1.40 Go version: go1.13.15 Git commit: 4484c46d9d Built: Wed Sep 16 17:02:36 2020 OS/Arch: linux/amd64 Experimental: false (base) emilio@unicorn:~$ docker-compose --version docker-compose version 1.17.1, build unknown

  
  
Posted 3 years ago

I'm on Ubuntu 18.04.3

  
  
Posted 3 years ago

Should have worked, the error you are getting is docker-compose parsing the yml file
Is this exactly the one from the trains-server repo ?

  
  
Posted 3 years ago

This error looks like docker-engine that supports only the v2 file format...

  
  
Posted 3 years ago

And got the same error

  
  
Posted 3 years ago

sudo curl -L " -s)-$(uname -m)" -o /usr/local/bin/docker-compose

  
  
Posted 3 years ago

Hmm let me check something

  
  
Posted 3 years ago

ElegantCoyote26 did you install 1.24.1 previously (as described in step 4)? I just want to make sure the instructions are correct

  
  
Posted 3 years ago

right, seems to have worked now!

  
  
Posted 3 years ago

Hi ElegantCoyote26
What's the docker / docker-compose version?
What's the OS?

  
  
Posted 3 years ago

yes, I just ran steps 6-12 again from https://allegro.ai/docs/deploying_trains/trains_server_linux_mac/

  
  
Posted 3 years ago

SuccessfulKoala55 Yup!

  
  
Posted 3 years ago