Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello! I'M New To Trains And Am Excited To Try Out The Stack. I Setup The Trains Server Using Docker Compose And The Services Are Running Successfully. However, When I Do Train Init And Copy The Config Generated I'M Getting The Following Error:

Hello! I'm new to trains and am excited to try out the stack. I setup the trains server using Docker Compose and the services are running successfully. However, when I do train init and copy the config generated I'm getting the following error: "Error: could not verify credentials" . I tried creating it multiple times and also copy-pasted the credentials manually. It still throws this error. Any suggestions on how to proceed?

  
  
Posted 3 years ago
Votes Newest

Answers 5


Hi NutritiousAnt96 , welcome! 🙂
This might be caused by the Trains SDK ( trains-init , in this case) not being able to reach the Trains Server on port 8008 - can you try doing curl http://<you-server-hostname-or-ip>:8008/ and sharing the response? It will be an error in any case, but the error details will help understand what's going on

  
  
Posted 3 years ago

Hi SuccessfulKoala55 Thanks for the quick response. You are right - there is an issue with the proxy. I received the following error with curl:

<html><head><title>504 Gateway Timeout</title></head> <body><h1>Gateway Timeout</h1> <p>Server error - server x.x.x.x is unreachable at this moment.<br><br>Please retry the request or contact your administrator.<br></p>. When I disabled the proxy I get : {"meta":{"id":"347820f898414cf185a30ae5fec2384f","trx":"347820f898414cf185a30ae5fec2384f","endpoint":{"name":"","requested_version":1.0,"actual_version":null},"result_code":400,"result_subcode":0,"result_msg":"Invalid request path /","error_stack":null},"data":{}}

  
  
Posted 3 years ago

Got it 🙂 I set NO_PROXY and it worked.

  
  
Posted 3 years ago

Happy to help 🙂

  
  
Posted 3 years ago

How do I run trains-init with no proxy?

  
  
Posted 3 years ago
311 Views
5 Answers
3 years ago
10 months ago
Tags
Similar posts