Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi! I Installed Self-Hosted Clearml Server Using

Hi! I installed self-hosted clearml server using https://artifacthub.io/packages/helm/allegroai/clearml . Because ClearML Server does not restrict access by default, i had to make a apiserver.conf file to k8s secret and mount it to clearml web server volume(/opt/clearml/config).
After re-installing clearml, i still can login without password. What am i missing?

  
  
Posted one year ago
Votes Newest

Answers 5


thank you CostlyOstrich36

  
  
Posted one year ago

i fount the solution!! i added configuration to helm’s values.yaml below.

additionalConfigs:
# services.conf: |
# tasks {
# non_responsive_tasks_watchdog {
# # In-progress tasks that haven’t been updated for at least ‘value’ seconds will be stopped by the watchdog
# threshold_sec: 21000
# # Watchdog will sleep for this number of seconds after each cycle
# watch_interval_sec: 900
# }
# }
apiserver.conf: |
auth {
# Fixed users login credentials
# No other user will be able to login
fixed_users {
enabled: true
pass_hashed: true
users: [
{
username: …
password: …
name: …
},
]
}
}

  
  
Posted one year ago

Oh, it didn’t generate conf file properly. I will try again

  
  
Posted one year ago

hello CostlyOstrich36 unfortunately, i also did it to api server just in case. but didn’t work

  
  
Posted one year ago

TartLeopard58 , I think you need to mount apiserver.conf to the api server. This is an API configuration 🙂

  
  
Posted one year ago