Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
The Webserver And Fileserver Are Containers Defined In Docker-Compose.Yml. But, The Clearml_File_Host Variable Is Always 'Undefined' In The Create Credentials Page Of The Web App As In The Attached Screenshot. Does It Mean My Configuration Has Something

The webserver and fileserver are containers defined in docker-compose.yml.

But, the CLEARML_FILE_HOST variable is always 'undefined' in the CREATE CREDENTIALS page of the web app as in the attached screenshot.
Does it mean my configuration has something wrong?

  
  
Posted one year ago
Votes Newest

Answers 23


Hi CostlyOstrich36 Thanks for your comment. I modified the environment variable to ' CLEARML_FILES_HOST= http://fileserver:8001 ' and restart the server. But, the credentials page still presents 'undefined' for the variable. Thanks anyway.

  
  
Posted one year ago

VivaciousReindeer64 this value is automatically parsed from the webapp URL by the webapp itself. I think there's a way to externally inject it, let me check

  
  
Posted one year ago

Hi VivaciousReindeer64 , I think you can simply edit the files_server to point to the correct port 🙂

  
  
Posted one year ago

VivaciousReindeer64 - you can try to add to the following to the webserver service environment section:
WEBSERVER__fileBaseUrl= https://192.168.1.145:8081

  
  
Posted one year ago

@<1526371986278715392:profile|VivaciousReindeer64> - Yes - please send me the docker-compose and the log of the webserver

  
  
Posted one year ago

@<1523703097560403968:profile|CumbersomeCormorant74> , Thanks a lot for your help. It is working now with your docker-compose.yml. The value of file_server is correctly displayed on the 'create credentials' page. Thank you so much!!!

  
  
Posted one year ago

@<1523703097560403968:profile|CumbersomeCormorant74> , Where can I find the web server log? I have an apiserver.log and a fileserver.log in /opt/clearml/logs. Nothing else.

  
  
Posted one year ago

Hi @<1523703097560403968:profile|CumbersomeCormorant74> ,
The web server keeps restarting after adding the volume parameter and configuration.json you suggested and restarting the docker-compose. Please let me know if you need logs to investigate. Thanks a lot for your efforts.

  
  
Posted one year ago

you can re-direct it to a file or just copy with the clipboard

  
  
Posted one year ago

Hi @<1526371986278715392:profile|VivaciousReindeer64> - please try this file:

  
  
Posted one year ago

sudo docker logs clearml-webserver

  
  
Posted one year ago

@<1523703097560403968:profile|CumbersomeCormorant74> , Attached are two zip files like below.
normal-log.zip contains docker-compose.yml and a webserver log when volumes is not used.
volume-log.zip have files when volumes is added to webserver section.
Thanks

  
  
Posted one year ago

@Oren Thank you so much for your efforts. I've tried your suggestion without success. I'm sure I restart the whole service with 'docker-compose down', and then 'up -d.'
By the way, did you add the line in the docker-compose.yml? The file doesn't accept '=' for key value mapping. So, I used following lines.

webserver:
command:
- webserver
container_name: clearml-webserver
environment:
WEBSERVER__fileBaseUrl: "http//192.168.1.145:8081"
# CLEARML_SERVER_SUB_PATH : clearml-web # Allow Clearml to be served with a URL path prefix.
image: allegroai/clearml:latest
restart: unless-stopped
depends_on:
- apiserver

  
  
Posted one year ago

@<1526371986278715392:profile|VivaciousReindeer64> - please check the following:

  • What do you get if you go to http//192.168.1.145:8080/configuration.json?
  • Can you check the log of the webserver docker (using sudo docker logs clearml-webserver ) - especially the beginning? Does it say anything about the fileBaseUrl?
  
  
Posted one year ago

@<1526371986278715392:profile|VivaciousReindeer64> - I added this and it worked:

- WEBSERVER__fileBaseUrl="
"

Maybe the quotes are required.

  
  
Posted one year ago

@Oren I've noticed typo in my setting. I used fileBaseUri instead of fileBaseUrl. However, fixing the typo doesn't solve the problem.

  
  
Posted one year ago

@<1526371986278715392:profile|VivaciousReindeer64> - I'll check it on my env

  
  
Posted one year ago

I also checked the log and it doesn't contain any case of fileBaseURL.

  
  
Posted one year ago

Make sure restart the compose ( docker-compose up -d )

  
  
Posted one year ago

The log is around 900kb and fileBaseURL is not found.

  
  
Posted one year ago

@<1523703097560403968:profile|CumbersomeCormorant74> Added the last two lines below in my docker-compose.yml without any success. Tried both http and https.

webserver:
command:
- webserver
container_name: clearml-webserver
environment:
WEBSERVER__fileBaseUri: https//192.168.1.145:8081

  
  
Posted one year ago

I'm using 80 instead of 8080. So, I tried None . The, I got {}.

  
  
Posted one year ago

Hi @<1526371986278715392:profile|VivaciousReindeer64> ,
I replicated your environment, and found the following solution:

  • In the docker-compose, add the following to the webserver section:
    volumes:
      - /opt/clearml/config:/mnt/external_files/configs
  • In the host machine, create a file /opt/clearml/config/configuration.json containing the following:
{
	"displayedServerUrls": {
		"filesServer": "
"
	}
}
  • restart the docker-compose: sudo docker-compose up -dI think this should do the trick. Please let me know if it worked
  
  
Posted one year ago
732 Views
23 Answers
one year ago
one year ago
Tags