Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
I Have Uploaded Dataset In Clearml With

I have uploaded Dataset in clearml with output_uri=s3:<s3url>:80 .

Can I ask if we do not include aws.s3.host=<s3host>:80 in clearml.conf, I.e. port 80, when your task calls Dataset.get(datadset_id) , does it always do https to s3 to get the data? I noticed logs stating that failure to get dataset from s3:<s3url>/bucket/..., err SSL error https://<s3url>/bucket/...
I have verified that data url is s3:<s3url>:80/... through clearml webpage, Dataset tab.

  
  
Posted one year ago
Votes Newest

Answers 2


Hi @<1523701070390366208:profile|CostlyOstrich36> , basically

  • I uploaded dataset using clearml Datasets. The output_uri is pointed to my s3, thus the dataset is stored in s3. My s3 is setup with http only.
  • When I retrieve the dataset for training, using Dataset.get() , I encountered ssl cert error as the url to retrieve data was https://<s3url>/... instead of s3://<s3url>/... which is http. This is weird as the dataset url is without https.
  • I am not too sure why and I suspect it got to do with the s3 host setting in clearml.conf.
    Any advice?
  
  
Posted one year ago

Hi @<1523701304709353472:profile|OddShrimp85> I'm not sure I understand, can you elaborate please on your use case?

  
  
Posted one year ago
726 Views
2 Answers
one year ago
one year ago
Tags