Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello Everyone, I’M Running Clearml Using Sagemaker And Its Strange I See No Plots Show Up When I Create A Matplotlib Plot After Initializing My Task, Wondering If Theres A Solution To This?

Hello everyone, I’m running ClearML using SageMaker and its strange i see no plots show up when i create a matplotlib plot after initializing my task, wondering if theres a solution to this?

  
  
Posted 11 months ago
Votes Newest

Answers 16


^ self hosted @<1523701070390366208:profile|CostlyOstrich36>

  
  
Posted 11 months ago

Hi @<1523701717097517056:profile|ScantMoth28> , what version of ClearML are you using? Are you using a self hosted server or the community one?

  
  
Posted 11 months ago

@<1523701070390366208:profile|CostlyOstrich36> maybe cause sagemaker is running in headless mode

  
  
Posted 11 months ago

going to double check that rn

  
  
Posted 11 months ago

^ it works if i do that and use the jupyter credentials from my work space settings.

  
  
Posted 11 months ago

although i wish it would use the credentials in my clearml.conf file automatically

  
  
Posted 11 months ago

the task is stil running

  
  
Posted 11 months ago

%env CLEARML_WEB_HOST={-----}
%env CLEARML_API_HOST={-----}
%env CLEARML_FILES_HOST=undefined
%env CLEARML_API_ACCESS_KEY={-----}
%env CLEARML_API_SECRET_KEY={-----}

  
  
Posted 11 months ago

and when i’m running it in sagemaker

  
  
Posted 11 months ago

The only difference that i notice is that when i run it locally the task is completed

  
  
Posted 11 months ago

import numpy as np
import matplotlib.pyplot as plt
import seaborn as sns
from clearml import Task

# Connecting ClearML with the current process,
# from here on everything is logged automatically
# Create a new task, disable automatic matplotlib connect
task = Task.init(project_name='Something', task_name='Something')

# Create plot and explicitly report as figure
N = 50
x = np.random.rand(N)
y = np.random.rand(N)
colors = np.random.rand(N)
area = (30 * np.random.rand(N))**2  # 0 to 15 point radii
plt.scatter(x, y, s=area, c=colors, alpha=0.5)
plt.show()
  
  
Posted 11 months ago

@<1523701070390366208:profile|CostlyOstrich36> yes it indeed shows up when running it locally

  
  
Posted 11 months ago

And if you run the same code locally everything is reported correctly?

  
  
Posted 11 months ago

but none the less I’ll continue with this work around thanks!

  
  
Posted 11 months ago

Name: clearml
Version: 1.9.1
  
  
Posted 11 months ago

still*

  
  
Posted 11 months ago
527 Views
16 Answers
11 months ago
11 months ago
Tags