Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello. Somehow When I Add The --Docker_Args Network=Host, The Task Became Failed To Run. Without --Docker_Args Network=Host. The Task Can Run. Anyone Know How To Fix This? Clearml-Task --Project Aaaa --Name Rtmdet-Ins_L_8Xb32-300E_Nitteshu.Py --Script To

Hello. somehow when I add the --docker_args network=host, the task became failed to run. without --docker_args network=host. the task can run. anyone know how to fix this?

clearml-task --project AAAA --name rtmdet-ins_l_8xb32-300e_nitteshu.py --script tools/train.py --args config=configs/rtmdet/rtmdet-ins_l_8xb32-300e_AAAA.py launcher=pytorch m=torch.distributed.launch nproc_per_node=4 nnodes=1 node_rank=0 master_addr=127.0.0.1 master_port=29500 --docker mmdet-3.0 --docker_args network=host --queue default

it showed some message like "docker: invalid reference format.
See 'docker run --help'."

  
  
Posted one year ago
Votes Newest

Answers 6


You probably need --network=host , with the 2 dashes

  
  
Posted one year ago

@<1555000557775622144:profile|CharmingSealion31> if I added 2 dashes, the following error appeared : clearml-task: error: argument --docker_args: expected one argument

  
  
Posted one year ago

and with --docker_args=--network=host ?

  
  
Posted one year ago

@<1555000557775622144:profile|CharmingSealion31> wow. somehow it works.
Thank you very much. you're awesome.
I wish they could write the help file more clear than this.
--docker_args DOCKER_ARGS
Add docker arguments, pass a single string

  
  
Posted one year ago

You're welcome 🙂
It's certainly because since the string --network=host begins with -- , the argument parser is considering it as an option as well, and not as the value of the previous option ( --docker_args ), so you need to escape it somehow for the parser to understand that you're actually trying to pass the value for the --docker_args option)

  
  
Posted one year ago

screen shoot look like this
image

  
  
Posted one year ago
655 Views
6 Answers
one year ago
one year ago
Tags