Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi All, I Was Trying To Reduce The Amount Of Logs Shown In The Cosnole Produced By Tqdm, So I Set

Hi all, I was trying to reduce the amount of logs shown in the cosnole produced by tqdm, so I set console_cr_flush_period: 30 . It works correctly when I run the script locally, but if I try to run it in an agent in docker mode I get a new console line every 5 seconds instead of every 30. Did anybody have the same issue?

  
  
Posted 11 months ago
Votes Newest

Answers 5


Hi @<1570220858075516928:profile|SlipperySheep79> , you need to apply the same setting on the machine that is running the agent. clearml.conf files are local and apply the settings only on the machine they're sitting on. In the Scale/Enterprise licenses there are configuration vaults that take care of this.

  
  
Posted 11 months ago

@<1570220858075516928:profile|SlipperySheep79> this setting does not reduce the number of lines but controls how often the console log is flushed - it basically just reduces the amount of API calls used when running an experiment that produces lots of console output

  
  
Posted 11 months ago

Where do you use tqdm?

  
  
Posted 11 months ago

I just have some for loop in some pipeline components, when processing some files. I know it increases the flush intervals and it’s working when run locally, I only see a new line from tqdm every ~30s. It’s just when I run the same script in docker using the agent I get a new line every ~5s

  
  
Posted 11 months ago

Hi, yes I’m using the same clearml.conf on the agent, in the logs I can see that console_cr_flush_period is set to 30

  
  
Posted 11 months ago
562 Views
5 Answers
11 months ago
11 months ago
Tags