Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello Everyone, Im Trying To Run The Hyper_Parameter_Optimizer.Py Example But Keep Running Into The Same Issue With Version Incompatibility, Could Anybody Tell Me What I'M Doing Wrong?

Hello everyone, Im trying to run the hyper_parameter_optimizer.py example but keep running into the same issue with version incompatibility, could anybody tell me what I'm doing wrong?

created virtual environment CPython3.10.12.final.0-64 in 132ms
  creator CPython3Posix(dest=/home/clearml/.clearml/venvs-builds/3.10, clear=False, no_vcs_ignore=False, global=False)
  seeder FromAppData(download=False, pip=bundle, setuptools=bundle, wheel=bundle, via=copy, app_data_dir=/home/clearml/.local/share/virtualenv)
    added seed packages: pip==24.0, setuptools==69.1.1, wheel==0.42.0
  activators BashActivator,CShellActivator,FishActivator,NushellActivator,PowerShellActivator,PythonActivator
Ignoring pip: markers 'python_version < "3.10"' don't match your environment
Collecting pip<22.3
  Using cached pip-22.2.2-py3-none-any.whl.metadata (4.2 kB)
Using cached pip-22.2.2-py3-none-any.whl (2.0 MB)
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 24.0
    Uninstalling pip-24.0:
      Successfully uninstalled pip-24.0
Successfully installed pip-22.2.2
Collecting Cython
  Using cached Cython-3.0.9-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (3.6 MB)
Installing collected packages: Cython
Successfully installed Cython-3.0.9
2024-03-12 16:58:12
Collecting tensorflow==2.16.1
  Using cached tensorflow-2.16.1-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (589.8 MB)
ERROR: Could not find a version that satisfies the requirement tensorflow_intel==2.16.1 (from versions: 0.0.1)
ERROR: No matching distribution found for tensorflow_intel==2.16.1
clearml_agent: ERROR: Could not install task requirements!
Command '['/home/clearml/.clearml/venvs-builds/3.10/bin/python', '-m', 'pip', '--disable-pip-version-check', 'install', '-r', '/tmp/cached-reqszm6ffdxf.txt']' returned non-zero exit status 1.
2024-03-12 16:58:12
Process failed, exit code 1
  
  
Posted one month ago
Votes Newest

Answers 2


Hi @<1678574809706926080:profile|ChubbyWhale74> , is it possible that you ran the original experiment on an newer python version and the agent is running with an older version?

  
  
Posted one month ago

Hi, yes you are right. I was only thinking to update the agent python version but running the original experiment on an older virtual environment solved it. Thanks!

  
  
Posted one month ago
94 Views
2 Answers
one month ago
one month ago
Tags