Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello, I Encountered An Issue While Deploying A Self-Hosted Clearml Server, By Following The Official Docker Compose

Hello, I encountered an issue while deploying a self-hosted clearml server, by following the official docker compose https://clear.ml/docs/latest/docs/deploying_clearml/clearml_server_linux_mac .

After running docker-compose -f /opt/clearml/docker-compose.yml up -d and open http://localhost:8080/settings/workspace-configuration , I could not see any place to create a credential. Why?

My setup:
Ubuntu 20.04.4 LTS WebApp: 1.7.0-232 • Server: 1.7.0-232 • API: 2.21

  
  
Posted one year ago
Votes Newest

Answers 13


image

  
  
Posted one year ago

Hi JumpyDragonfly13 , can you try going to http://localhost:8080/login ? What happens when you open developer tools (F12) when browsing currently

  
  
Posted one year ago

The 2nd attached screenshot is for URL http://localhost:8080/settings/workspace-configuration .

  
  
Posted one year ago

CostlyOstrich36

  
  
Posted one year ago

I'm accessing both using SSH tunneling & the same domain

I guess we found the culprit 🙂

  
  
Posted one year ago

Browser thinks it's the same backend because of the domain

  
  
Posted one year ago

I'm curious as to why you weren't redirected to login page

  
  
Posted one year ago

Now try logging in

  
  
Posted one year ago

You're right.

I have set up 2 self-hosted clearml server, and I'm accessing both using SSH tunneling & the same domain ( http://localhost:8080 ). After logging out from the 1st clearml website, the 2nd website did redirect me to the login page.

Therefore, the previous error of the 2nd web app is that it was using a wrong cookie from the 1st web app.

  
  
Posted one year ago

Feels like a cookie issue to me

  
  
Posted one year ago

CostlyOstrich36 Thanks! After loging in, everything works without any error.

So it seems the root cause is just that I haven't logged in for the 1st time?

  
  
Posted one year ago

Also in network section of developer tools. What is returned to one of the 400 messages?

  
  
Posted one year ago

I'm curious too.

It did redirect when I set it up last time few days ago (on a different Ubuntu server). However, this time it seems not redirecting me. How could I further debug or investiage this isssue?

  
  
Posted one year ago
546 Views
13 Answers
one year ago
12 days ago
Tags