Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi All! I Am Trying To Run The Notebook From The Remote Server Using Aws. It Seems Like I Successfully Installed Clearml Using !Pip Install Clearml Command, But When I Am Trying To Run !Clearml-Init I Got The Following Error: /Bin/Bash: Clearml-Init: Comm

Hi all! I am trying to run the notebook from the remote server using AWS.
It seems like I successfully installed clearML using !pip install clearml command, but when I am trying to run !clearml-init I got the following error: /bin/bash: clearml-init: command not found. It is like it did not install it… ?
How can I fix it?

  
  
Posted one year ago
Votes Newest

Answers 32


image

  
  
Posted one year ago

image

  
  
Posted one year ago

YAY! I'm happy to hear!

  
  
Posted one year ago

I found that I can change Kernel and choose env

  
  
Posted one year ago

or /home/<USER_NAME>/clearml.conf

  
  
Posted one year ago

try like this

  
  
Posted one year ago

'CLEARML_CONFIG_FILE': '/home/ubuntu/notebooks/clearml.conf'

  
  
Posted one year ago

'CLEARML_CONFIG_FILE': '/home/ubuntu/clearml.conf'

  
  
Posted one year ago

I had the same error in Colab actually

  
  
Posted one year ago

but the error is the same (

  
  
Posted one year ago

the same error

  
  
Posted one year ago

I tried different references and nothing works. funny enough that clearml-init sees the file and reports “Configuration file already exists: /home/ubuntu/clearml.conf” but then the task.init does not see it

  
  
Posted one year ago

I'm being silly. You're actually directing it to the file itself to where it resides

  
  
Posted one year ago

Can I assume that you've installed the latest version of ClearML?

  
  
Posted one year ago

This looks more appropriate if the username itself is "ubuntu"

  
  
Posted one year ago

but it is located in the /notebooks

  
  
Posted one year ago

yeah, the same(((

  
  
Posted one year ago

Try setting the following environment envs:
%env CLEARML_WEB_HOST= %env CLEARML_API_HOST= %env CLEARML_FILES_HOST= %env CLEARML_API_ACCESS_KEY=... %env CLEARML_API_SECRET_KEY=...and try removing the clearml.conf file 🙂

  
  
Posted one year ago

OMG I tried different environment and started everything from scratch and it seems it works…

  
  
Posted one year ago

Successfully installed clearml-1.4.1 furl-2.1.3 orderedmultidict-1.0.1 pyjwt-2.1.0

  
  
Posted one year ago

Thanks for your help and support ☺

  
  
Posted one year ago

Also please note that your path is wrong

  
  
Posted one year ago

yes

  
  
Posted one year ago

I can ssh for sure but I do not know how to check the environment 😳

  
  
Posted one year ago

when I check os.environ I see
'CLEARML_CONFIG_FILE': '/clearml.conf'})

  
  
Posted one year ago

Because now I have successfully import clearml and task but have an error with task initializing
ValueError: ClearML configuration could not be found (missing~/clearml.confor Environment CLEARML_API_HOST) To get started with ClearML: setup your ownclearml-server, or create a free account at

  
  
Posted one year ago

You must perform Task.init() to have something reported 🙂

  
  
Posted one year ago

Also try with
!pip3 install clearml

  
  
Posted one year ago

Are you sure that the file is on the server? Can you access it?

  
  
Posted one year ago

os.environ['CLEARML_CONFIG_FILE']='~/clearml.conf'

  
  
Posted one year ago
6K Views
32 Answers
one year ago
one month ago
Tags
Similar posts