Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi There. I Have My Own Clearml Server Working On

Hi there. I have my own clearml server working on http://clearml.10.68.0.250.nip.io , i try to push my artefact on a minio server hosted at the http://minio.10.68.0.250.nip.io address. I create a task in a bucket "simclr" and everything works fine. I create my checkpoints in the S3 minio server but i can't download (download_button.png) from the web interface the stored file, i get asked from some credentials (s3_credentials.png) but i don't know how to fix them, and i put the credentials i specified for this bucket the url is rewritted to one aws address (aws_address.png). I don't know where to write some configurations parameters

  
  
Posted one year ago
Votes Newest

Answers 14


Hi MotionlessCoral18 , can you check the configuration you added under you profile? is the bucket entry contains the HOST (ENDPOINT) section?

  
  
Posted one year ago

Most of the time it is due to a bad parsing of the ip adress. You need to be sure the ip adress is correctly parsed and for this, i need to specify the port used for my minio server even it is a standard http (80) port. Then 'address:80' works but not "address" alone

  
  
Posted 8 months ago

I define the HOST ( ENDPOINT) like this but it doesn't change anything

  
  
Posted one year ago

Okay but do you put the bucket name ? if so, before the port ?

  
  
Posted 8 months ago

FYI we use the port to distinguish between AWS and local S3

  
  
Posted one year ago

i use a proxy and the port is 80, i need to write it ?

  
  
Posted one year ago

do you have the port at the end?

  
  
Posted one year ago

Dear Jean-Fran├žois and Shay,
I am still not able to use it properly.
I have the same setup. what did you put in your clearml.conf ?
credentials: [ { host : url.for.api.minio:80 key: secret: multiport: secure: false } ] ... default_output_uri: " "
is that correct ?

  
  
Posted 7 months ago

I solved it with :
credentials: [ { host : url.for.api.minio:443 key: secret: multiport: secure: true } ] ... default_output_uri: "

  
  
Posted 7 months ago

Great, I will try this

  
  
Posted 8 months ago

He ask me for credentials for the root server (minio.10.68.0.250.nip) and not for the bucket where it is stored (minio.10.68.0.250.nip/simclr) only this bucket has read/write permission.

  
  
Posted one year ago

By default, i put nothing in the task but when i use a ClearMLSaver like this
ClearMLSaver(logger, output_uri=" ")where clearml is my bucket.

  
  
Posted 8 months ago

Hello MotionlessCoral18 and DeterminedCrab71 , I have exactly the same problem. What did you put in the output_uri ? minio.10.68.0.250.nip/simclr:80 ? In the Task.init ?
Many thanks

  
  
Posted 8 months ago

Ok, it works i need to specify :80 also in the output_uri from my python file !

  
  
Posted one year ago