Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello, I Want To Update Allegro. I Found The Link:

Hello,
I want to update allegro.
I found the link:
https://allegro.ai/clearml/docs/docs/deploying_clearml/clearml_server_es7_migration.html
But with this guide I can only update it to 0.16.0
I want to upgrade it to 1.0.0
Does anyone have a guide for 1.0.0?

  
  
Posted 3 years ago
Votes Newest

Answers 8


I still have access to the gui

  
  
Posted 3 years ago

btw - what do you mean by "So I could not stop allegro."? Can't you do docker-compose down ?

  
  
Posted 3 years ago

Now I ran docker-compose down
But the allegro server is still available.

  
  
Posted 3 years ago

UnsightlySeagull42 note step #4 in the above-mentioned upgrade instructions:
If you are upgrading from Trains Server to ClearML Server, rename /opt/trains and its subdirectories to /opt/clearml.

  
  
Posted 3 years ago

UnsightlySeagull42 The upgrade process is slightly different depending on the environment in which you've deployed your ClearML server (e.g. for a https://allegro.ai/clearml/docs/docs/deploying_clearml/clearml_server_linux_mac.html#upgrading ).
Note the document you are referring to only applies once when you're moving from the older pre-0.16 versions in which case DB migration is required.
If your server is more up to date (0.16 and newer) you should be OK with the link above.

  
  
Posted 3 years ago

thank you for the information.
I am using the same GUI on 2 servers.
On both servers the following path did not exist:
/opt/trainsSo I could not stop allegro.
I run the commands on 1 server to upgrade it. But on the gui there is still the old version.
Does anyone know how I can proceed?

  
  
Posted 3 years ago

So you must have another instance running..
Try docker ps and see if any containers are up

  
  
Posted 3 years ago

UnsightlySeagull42 this upgrade process is a special upgrade if your current server version is v.0.15.0
Otherwise, as FrothyDog40 just said, simply follow the upgrade section of the Linux/MacOS installation guide: https://allegro.ai/clearml/docs/docs/deploying_clearml/clearml_server_linux_mac.html#upgrading

  
  
Posted 3 years ago